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A program on your Windows Server 2003-based computer that queries counters unexpectedly quits when it runs out of memory


View products that this article applies to.

Symptoms

When you try to run a program on your Microsoft Windows Server 2003-based computer that queries specific costly counters, the program may unexpectedly quit. Costly counters are counters for data collection that are either processor-intensive or memory-intensive. Therefore, costly counters are counters that take a long time to collect data from. Costly counters do not appear in the System Monitor tool. You can view costly counters only by using the Showperf.exe program or other performance-related tools in the Windows Server 2003 Resource Kit. The following counters are examples of costly counters:
  • Image
  • Process Address Space
  • Thread Details

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Cause

This problem occurs because your program runs out of memory. The Perfproc.dll file has a memory leak. Therefore, memory that is used by the Perfproc.dll file is not freed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size    File name      Platform
   -----------------------------------------------------------------
   18-May-2004  22:49  5.2.3790.173  68,608  Perfproc.dll   IA-64
   18-May-2004  22:54  5.2.3790.173  34,304  Wperfproc.dll  IA-64
   18-May-2004  22:54  5.2.3790.173  34,304  Perfproc.dll   x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB842649, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 842649
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 540