Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The counters for the MSExchangeDSAccess service in System Monitor may not be available after a failover in an Exchange Server 2003 cluster


View products that this article applies to.

Symptoms

When you use System Monitor to view performance objects on a Microsoft Exchange Server 2003 computer that is in a clustered environment, the counters for the MSExchangeDSAccess service may not be available or may display performance data that is not correct.

↑ Back to the top


Cause

This problem may occur when the active node in the cluster experiences a failover. Because of the registry checkpoint process, the following subkey is overwritten on the passive node in the Exchange server cluster:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ServicesMSExchangeDSAccess
The MSExchangeDSAccess entry values must remain unique for each computer.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Microsoft Exchange Sever 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was corrected in Exchange Server 2003 Service Pack 1 (SP1).

↑ Back to the top


Keywords: KB842121, kbexchange2003sp1fix

↑ Back to the top

Article Info
Article ID : 842121
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 282