Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive error messages when you create a high volume of new user objects by using Microsoft Provisioning Server


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you create a high volume of user objects with Microsoft Provisioning Server (MPS), you may receive the following error messages:
(The server is not operational./ADsGetObject/SetPropertiesBase) returned from MPS. 'LDAP://sad01.shve.com/cn=user5@Xorg42.com,OU=Xorg42,OU=HVE,OU=Hosting,DC=shve,DC=com'./The server is not operational./ADsGetObject/SetPropertiesBase Error: 0x8007203a user5 duration: 2.71875 seconds

An error occurred: An operations error occurred. Facility: LDAP Provider ID no: 80072020 Microsoft CDO for Exchange Management/SetProxyAddressesForUser failed for this user with email alias: ''. Contact SA. Error: 0x80072020 user6 duration: 2.25 seconds

An error occurred: Unable to open object 'LDAP://sad01.shve.com/cn=user8@Xorg42.com,OU=Xorg42,OU=HVE,OU=Hosting,DC=shve,DC=com'./The server is not operational./ADsGetObject/SetPropertiesBase Error: 0x8007203a user8 duration: 1.375 seconds

An error occurred: Unable to open object 'LDAP://sad01.shve.com/cn=user10@Xorg42.com,OU=Xorg42,OU=HVE,OU=Hosting,DC=shve,DC=com'./The server is not operational./ADsGetObject/GetProperties Error: 0x8007203a user10 duration: 2.375 seconds

↑ Back to the top


Cause

When you create a high volume of user objects through MPS, such as performing a migration or conducting benchmark tests, you might see a set of errors that are returned by MPS that are related to creating user objects. These errors occur when you create user objects very fast, and network resources on the domain controllers and on the MPS servers run out.

↑ Back to the top


Resolution

To resolve this problem, increase the values for the registry subkeys that are related to the networking on both the domain controller computer that the MPS server directs the provisioning request to, and on the MPS server computer. To do this, modify the values for the relevant registry subkeys by using Registry Editor.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To modify the registry values, follow these steps:
  1. Click Start, and then click Run. The Run dialog box appears.
  2. In the Open box, type regedit.
  3. Click OK.
  4. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\currentControlSet\services\tcpip\parameters
  5. Under the Name column, right-click the maxuserport dword value in the right pane, and then click Modify. The Edit DWORD Value dialog box appears.
  6. In the Value data box, type 0xfffe, and then click OK.
  7. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\currentControlSet\services\tcpip\parameters
  8. Under the Name column, right-click the TcpTimedWaitDelay dword value in the right pane, and then click Modify. The Edit DWORD Value dialog box appears.
  9. In the Value data box, type 30.
  10. Close Registry Editor.
Note You must restart the computer after you make these changes.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


More information

If the large number of requests for network resources heavily loads your computer, Microsoft recommends that you increase the value for the MaxUserPort registry entry but not for the TcpTimedWaitDelay registry entry. The timed delay waits for any other messages that might come in on the same network connection. In a benchmark situation, this behavior is well known, and using a small value is fine. In production, there is a slightly higher risk that a port may be released too soon. This means that Transmission Control Protocol (TCP) might release connection resources before the connection is complete. Therefore, the server must use additional resources to reestablish the connection.

Steps to reproduce the behavior

Create a high number of users in your Microsoft Hosted Exchange environment with MPS, and then monitor the results. You may notice the behavior that is mentioned in the "Symptoms" section.

↑ Back to the top


References

For more information about Microsoft Provisioning System, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbregistry, kbdomain, kbuser, kbmigration, kbnetwork, kbprb, kbresource, KB842038

↑ Back to the top

Article Info
Article ID : 842038
Revision : 5
Created on : 10/22/2007
Published on : 10/22/2007
Exists online : False
Views : 272