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Cryptographic signatures are not successfully validated when you use CDOEX to configure a transport event sink in Exchange Server 2003


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

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Symptoms

Cryptographic signatures are not successfully validated when the following conditions are true:
  • You are using Microsoft Exchange Server 2003.
  • You use Microsoft Collaboration Data Objects for Microsoft Exchange Library (CDOEX) to configure a transport event sink.
  • The transport event sink handles incoming e-mail messages and validates cryptographic signatures.

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Cause

This problem occurs because CDOEX alters the S/MIME content of the message in the transport event sink. Therefore, the S/MIME validation of the cryptographic signature is not successful.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Exchange Server 2003 Service Pack 1 installed on your computer.

Restart requirement

You do not have to restart your computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size       File name
   ---------------------------------------------------------
   23-Jun-2004  04:33  6.5.7232.4   3,926,016  Cdoex.dll        
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.After you apply this hotfix, you must add the CDOHighFidelityInSinks entry to the registry:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters
  3. Right-click Parameters, point to New, and then click DWORD Value.
  4. Type CDOHighFidelityInSinks, and then press ENTER.
  5. Right-click CDOHighFidelityInSinks, and then click Modify.
  6. In the Value data box, type 00000001, and then click OK.
  7. Quit Registry Editor.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about terms and about file naming conventions, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� New naming schema for Exchange Server software update packages

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Keywords: KB841997, kbbug, kbfix, kbexchange2003presp2fix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 841997
Revision : 9
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 326