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Migration of some user accounts does not succeed when you try to migrate user accounts from one forest to another forest in Windows Server 2003


View products that this article applies to.

Symptoms

When you use version 2 of the Active Directory Migration Tool (ADMT) to try to migrate user accounts from one forest to another forest in Microsoft Windows Server 2003, you may experience all the following symptoms:
  • The migration process is successful except for the migration of particular user accounts.
  • You receive the following error message when you try to migrate each problem account:
    ERR2:7422 Failed to move object CN=UserName, hr=80070057 The parameter is incorrect.
  • When you use Active Directory Users and Computers on a domain controller in the source forest to view the problem accounts, the accounts do not appear to be locked out. For example, the Account is locked out check box is not selected when you view the Account tab in the UserName Properties dialog box of each account. However, if you run the LockoutStatus.exe tool to determine the lock-out status of the problem accounts, you receive results that indicate that the accounts are locked out. Additionally, if you export the account information to an Ldifde file and view the problem accounts, the lock-out time value is set to a value that is other than 0 (zero).

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Cause

This problem occurs if all the following conditions are true:
  • A problem account is locked out because the Account lockout threshold value was exceeded when a user tried to use that account to log on.
  • An administrator does not manually unlock the account.
  • Windows automatically unlocks the account after the Account lockout duration value is reached.
  • The user does not use the account to log on before you perform the account migration operation.
This problem occurs because when Windows automatically unlocks the account, the account lock-out time value retains the nonzero value that was assigned when the account was locked out until that user uses that account to log on. When an administrator manually unlocks an account, the account lock-out time value is set to zero.

When you use ADMT to migrate an account, if the account lock-out time value is a nonzero value, the account is considered to be locked out, and is not migrated successfully. In this scenario, when you try to migrate an account that was unlocked automatically after the Account lockout duration value is reached, and the user has not subsequently used that account to log on, you are unsuccessful because the account lock-out time value retains a nonzero value.

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Resolution

Hotfix information

Note This hotfix should be applied to all domain controllers in the target domain. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
   Date         Time   Version       Size       File name
   ------------------------------------------------------
   12-May-2004  01:16  5.2.3790.171  1,527,808  Ntdsa.dll
Windows Server 2003, 64-bit editions
   Date         Time   Version       Size       File name
   ------------------------------------------------------
   12-May-2004  01:10  5.2.3790.171  4,043,776  Ntdsa.dll

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Workaround

To work around this problem, use one of the following methods:

Method 1: Use the account to log on

Before you try to migrate the accounts, request that the users use the accounts that you plan to migrate to log on. This resets the account lock-out time value to zero. Therefore, the migration operation will be successful.

Method 2: Modify the account options

Log on to the domain controller where the accounts are located, and then modify the account options for each user account. For example, click to clear the User must change password at next logon check box. This causes the bad password count to be reset to a zero value. To change this setting:
  1. Start Active Directory Users and Computers.
  2. Locate an account, right-click that account, and then click Properties.
  3. Click the Account tab, click to clear the User must change password at next logon check box, and then click OK.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

To obtain the LockoutStatus.exe tool, visit the following Microsoft Web site: For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB841820, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 841820
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 324