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The Exchange Connector for Lotus Notes stops and you receive a "The instruction at 0x00E26E1E referenced memory at 0x00000000" error message in Exchange Server 5.5


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows Registry

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Symptoms

The Microsoft Exchange Connector for Lotus Notes service may stop, and you may receive the following error message:
The instruction at 0x00E26E1E referenced memory at 0x00000000. The memory could not be read.
Additionally, if you try to start the Microsoft Exchange Connectivity Controller, the following events may be recorded in the Event Viewer:

Type: Error
Event ID: 510
Source: MSExchangeNOTES
Category: Exchange to Notes Conversion
Description:
Error {Service timeout}: The application failed to initialize.

Type: Error
Event ID: 31019
Source: MSExchangeNotes
Category: Transport to Exchange
Description:
All required exchange server processes are not running.

Type: Error
Event ID: 31005
Source: MSExchangeNotes
Category: Transport to Exchange
Description:
Exchange server is not running. Please start it before proceeding.

Type: Error
Event ID: 31003
Source: MSExchangeNotes
Category: Transport to Exchange
Description:
Error attempting to initialize Exchange server interface. GRC=(the subtask is not running).


Note You may have to set the Exchange Connector for Lotus Notes diagnostic logging to the maximum level to record these events. For information about increasing the diagnostic logging for the Exchange Connector for Lotus Notes, see the "More Information" section.

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Cause

This issue may occur when there is information in the Exchconn.ini file that is not correct.

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Resolution

To work around this issue, correct the information in the Exchconn.ini file. To do this, follow these steps.
1.Start a text editor, such as Notepad, and then open the Exchconn.ini file.

The Exchconn.ini file is located in the following folder, where Drive is the hard disk drive that Exchange Server 5.5 is installed on:
Drive:\Exchsrvr\Connect\Exchconn
Important Before you make any changes to the Exchconn.ini file, make a copy of the file for backup purposes.
2.The information in the CONTROL section of the Exchconn.ini file must appear as follows:
[CONTROL]
title = Microsoft Exchange Connectivity Controller (Command-Line)
rootdir = Drive:\Exchsrvr\Connect\Exchconn

If the information is not similar, replace it with this text.
3.The information in the LME section of the Exchconn.ini file must appear as follows, where Organization is your organization name, SiteName is the name of your Exchange site, and ExchangeServerName is the name of your Exchange server:
[LME]
ORG=Organization
SITE=SiteName
SERVER=ExchangeServerName
If the information is not similar, replace it with this text.
4.Verify that the LME-NOTES section has the correct Lotus Notes foreign domain information.
5.Save the Exchconn.ini file, and then quit Notepad.
6.Click Start, click Run, type regedit, and then click OK.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
7.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeCoCo
8.Verify that the following value appears in the ImagePath entry:
Drive:\ EXCHSRVR\Connect\Exchconn\lscntrl.exe -cexchconn.ini -nCONTROL-SERVICE -pCONTROL-SERVICE -lDrive:\EXCHSRVR\Connect\Exchconn -vMSExchangeCoCo
If the value does not appear, modify it. To do this, click ImagePath, click Modify on the Edit menu, type that value in the Value data box, and then click OK.

Note The data type for the ImagePath value is REG_EXPAND_SZ.
9.Stop and then restart the Exchange Connectivity Controller.
10.Stop and then restart the Exchange Connector for Lotus Notes.

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More information

You can find more information about the Exchconn.ini file in the Linkini.hlp file that is located in the Drive:\Exchsrvr\Connect\Exchconn folder.
For additional information about how to increase diagnostic logging for the Exchange Connector for Lotus Notes, click the following article number to view the article in the Microsoft Knowledge Base:
295307 How to enable and increase logging for Microsoft Exchange Connectivity Controller connectors

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Keywords: KB841671, kbprb

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Article Info
Article ID : 841671
Revision : 3
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 244