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Event ID 5501 and event ID 6524 are logged when DNS requests an incremental zone transfer in Windows Server 2003


View products that this article applies to.

Symptoms

When Microsoft Windows Server 2003 Domain Name System (DNS) requests an incremental zone transfer from a Berkeley Internet Name Domain (BIND) server, the following events are logged in the system event log:

Event 5501
Source: DNS
Type: Warning

Description: DNS Server encountered bad packet from IP Address. Packet processing leads beyond packet length.

Event 6524
Source: DNS
Type: Error

Description: Invalid response from master DNS server at IP Address during attempted zone transfer of zone. Check DNSServer and ensure that it is authoritative for this zone. This can be done by viewing or updating the list of authoritative servers for the zone. When using the DNS console, select zone ZoneName Properties at server IP Address and click the Name Servers tab. If needed, you can add or update this server in the list there. As an alternative solution, you could also modify settings in the Zone Transfer tab to allow transfer of the zone to this and other DNS servers, where DNSServer is the name of your DNS server, IP Address is the IP address of your master DNS server, and ZoneName is the name of your DNS zone.

However, a full zone transfer is completed correctly when you click Transfer from Master in the DNS console.

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Cause

This problem occurs because the BIND server sends a full zone transfer instead of an incremental transfer. A full zone transfer contains a start of authority (SOA) record at the start of the transfer, followed by the records, and then the second SOA record at the end of the transfer.
After DNS receives the second SOA record, DNS automatically switches to a full zone transfer. However, DNS then detects the first zone record as the SOA record. Because of this, DNS incorrectly detects a bad packet and reports the bad packet error as event ID 5501 and event ID 6524. DNS then ends the zone transfer.

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Resolution

Windows Server 2003 64-Bit Edition hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   20-May-2004  23:30  5.2.3790.173    1,024,512  Dns.exe      IA-64
   20-May-2004  23:30  5.2.3790.173      423,424  Wdns.exe     x86

Windows Server 2003 32-Bit Edition hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   21-May-2004  02:29  5.2.3790.173      423,424  Dns.exe 

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Workaround

To work around this problem, manually initiate a full zone transfer by using the DNS console. To this, follow these steps:
  1. Click Start, point to Administrative Tools, and then click DNS.
  2. Expand DNS, and then expand Forward Lookup Zones.
  3. Right-click the secondary zone where you want to initiate the full zone transfer, and then click Transfer from Master.

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Keywords: kbautohotfix, kbqfe, kbdns, kbserver, kbinterop, kbwinserv2003presp1fix, kbevent, kbfix, kbbug, kbhotfixserver, KB841647

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Article Info
Article ID : 841647
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 699