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You receive an error message when you start a Windows Server 2003-based computer by using the ADS Deployment Agent


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Symptoms

When you start a Windows Server 2003-based computer by using the Microsoft Windows Automated Deployment Services (ADS) Deployment Agent, you may receive an error message that is similar to the following:
Windows could not start due to an error while booting from a RAMDISK. Windows failed to build a bootable RAMDISK IMAGE.
The following message is logged in the application event log:

Event Type: Warning
Event Source: ADSBUILDER Event
Category: Builder
Event ID: 771
Date: 4/1/2004
Time: 1:19:24 PM
User: N/A
Computer: Computer Name

Description:

The device PCI\VEN_14E4&DEV_1648&SUBSYS_164814E4&REV_02&CC_020000 was not found in the repository {e597073d-bca9-4935-8257-25530a5677d0}. Please ensure that you have configured the repository correctly and that the inf directories contain an .inf file that describes this device.

For more information, see the Help and Support Center at http://support.microsoft.com.

The Adssvcbuild.log file may contain entries that are similar to the following:
[2548] 04-06 11:41:20:482: Attaching ramdisk at {2d85e26a-a155-3a59-8a1b-189a75d1966c}
[2548] 04-06 11:41:20:482: Detaching ramdisk at {2d85e26a-a155-3a59-8a1b-189a75d1966c}
[2548] 04-06 11:41:20:482: Error opening ramdisk volume \Device\Ramdisk{2d85e26a-a155-3a59-8a1b-189a75d1966c}.

[2548] 04-06 11:41:20:482: Error(d0000034)
[2548] 04-06 11:41:20:482: Found device ACPIAPIC_MP in Product {e597073d-bca9-4935-8257-25530a5677d0} from INF (hal.inf)
[2548] 04-06 11:41:20:482: Found device *PNP0C08 in Product {e597073d-bca9-4935-8257-25530a5677d0} from INF (acpi.inf)
[2548] 04-06 11:41:20:482: Found device *PNP0A03 in Product {e597073d-bca9-4935-8257-25530a5677d0} from INF (machine.inf)
[2548] 04-06 11:41:20:482: Device Entry NOT FOUND for PCI\VEN_14E4&DEV_1648&SUBSYS_164814E4&REV_02&CC_020000

[2548] 04-06 11:41:20:482: Error(81070303)
[2548] 04-06 11:41:20:482: Failed to find device PCI\VEN_14E4&DEV_1648&SUBSYS_164814E4&REV_02&CC_020000 in product {e597073d-bca9-4935-8257-25530a5677d0}.

[2548] 04-06 11:41:20:482: Error(81070303)
[2548] 04-06 11:41:20:482: Failed to Add Primary NIC Device

[2548] 04-06 11:41:20:482: Error(81070303)

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Cause

This issue occurs if Microsoft Windows Server 2003 does not support the network adapter that is installed on the computer that you started by using the ADS Deployment Agent.

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Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To resolve this issue, follow these steps:
  1. Install the hotfixes that are in Microsoft Knowledge Base articles 830413 and 829053.

    For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
    830413 The ADS Deployment Agent Builder Service does not correctly parse the latest .inf file formats
    829053 Vendor-supplied drivers that you add to the ADS Deployment Agent Builder service repository are not installed
  2. Download the latest drivers for the network adapter to your ADS server. Next, copy all the driver files for the network adapter to the following folder:

    Drive:\Program Files\Microsoft ADS\NBS\Repository\User\PreSystem
    Note In this folder, Drive is a placeholder for the drive letter where ADS is installed.

    When you copy the network adapter driver files to this folder, do not create subdirectories or include Txtsetup.oem files.

    To verify that the driver you used is the correct driver, perform a typical installation on the computer that you started by using the ADS Deployment Agent.
  3. Restart the Adsbuilder service, as follows:
    1. Click Start, click Run, type cmd, and then click OK.
    2. At the command prompt, type net stop adsbuilder, and then press ENTER.
    3. At the command prompt, type net start adsbuilder, and then press ENTER.

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More information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

For additional information about the driver installation, turn on logging. If you turn on logging, a file is created in the following folder:
Drive:\Windows\Tracing\Adsbuildsvc.log
Note In this folder, Drive is a placeholder for the drive letter where Windows is installed.

To turn on logging, follow these steps:
  1. Log on to your computer as an administrator.
  2. Click Start, click Run, type regedit in the Open box, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\AdsBuilderSvc
  4. Right-click under the last value in the right pane, point to New, and then click DWORD Value.
  5. Type EnableFileTracing, and then press ENTER.
  6. Right-click EnableFileTracing, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Close Registry Editor.

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Keywords: KB841550, kbprb, kbtshoot

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Article Info
Article ID : 841550
Revision : 5
Created on : 10/30/2006
Published on : 10/30/2006
Exists online : False
Views : 239