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You cannot access encrypted files after you log on by using a password that was changed programmatically in Windows Server 2003


View products that this article applies to.

Symptoms

When you log on to a Microsoft Windows Server 2003-based computer that has a password that was changed programmatically, you may not be able to access encrypted files. Additionally, you may receive an error message that states that access is denied.

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Cause

This problem may occur in either of the following scenarios:
  • The password for the local user account was changed by using the Active Directory Service Interfaces (ADSI) ChangePassword method in a Visual Basic script.

    In this scenario, the Lsasrv.dll file does not correctly parse the local computer name that is contained in the Visual Basic script.
  • The password for the local user account was changed by using "\\ComputerName� as the first parameter of the NetUserChangePassword function.

    In this scenario, the computer name is not parsed correctly because the program calls the NetUserChangePassword function with a non-NULL value that has a "\\" prefix. For example "\\NETBIOSLOCALMACHINENAME." If the value that is passed to the NetUserChangePassword function is NULL or NETBIOSLOCALMACHINENAME, this problem does not occur.

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Workaround

To work around the problem that was caused by the second scenario in the "Cause" section, reverse the password change that you made. Then, perform the password change again by using a NULL value for the NetUserChangePassword function. To do this, follow these steps:
  1. Call the NetUserChangePassword function with the following parameters to change the password back to the previous password:
    NetUserChangePassword(\\NETBIOSLOCALMACHINENAME, ...)
  2. Call the NetUserChangePassword function again with a NULL value to change the password again.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit versions
   Date         Time   Version            Size  File name
   ---------------------------------------------------------
   19-Nov-2004  01:45  5.2.3790.212     64,000  Eventlog.dll
   19-Nov-2004  01:45  5.2.3790.233    801,792  Lsasrv.dll
   18-Nov-2004  19:56  5.2.3790.233     13,312  Lsass.exe
Windows Server 2003 64-bit versions
   Date         Time   Version            Size  File name
   ---------------------------------------------------------
   18-Nov-2004  12:21  5.2.3790.212    167,936  Eventlog.dll
   18-Nov-2004  12:21  5.2.3790.233  2,039,296  Lsasrv.dll
   18-Nov-2004  06:20  5.2.3790.233     15,360  Lsass.exe

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB841105

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Article Info
Article ID : 841105
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 495