Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Event ID 7024 and the ISA Server Control service does not start on your ISA Server 2000 computer


View products that this article applies to.

Symptoms

After you restart your Microsoft Internet Security and Acceleration (ISA) Server 2000 computer, the following event is logged in the system event log:

Event Type: Error
Event ID: 7024
Source: Service Control Manager
Description:
The Microsoft ISA Server Control service terminated with service-specific error 278540.

↑ Back to the top


Cause

This behavior may occur if the Routing and Remote Access service starts before the ISA Server Control service. You may experience this behavior after you install the Message Screener component of ISA Server 2000. Installing the Message Screener component may change service dependencies.

↑ Back to the top


Resolution

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this behavior, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. Right-click Routing and Remote Access, and then click Stop.
  3. Right-click Microsoft ISA Server Control, and then click Start.
  4. Click Start, click Run, type regedt32 in the Open box, and then click OK.
  5. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess
  6. Double-click the DependOnService entry.
  7. In the Data box, position the pointer below any existing values.
  8. Type isactrl, and then click OK.
  9. Quit Registry Editor.
  10. In the Services snap-in, right-click Routing and Remote Access, and then click Start.
  11. Quit the Services snap-in.

↑ Back to the top


Keywords: KB840683, kbprb, kbfirewall, kbtshoot

↑ Back to the top

Article Info
Article ID : 840683
Revision : 4
Created on : 7/19/2004
Published on : 7/19/2004
Exists online : False
Views : 247