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Intermittent Stop errors in IA64 editions of Windows Server 2003


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003 IA64 Edition-based computer, you may experience data corruption or memory corruption. Therefore, intermittent Stop errors that are similar to one of the following may be generated:
*** STOP: 0x0000009C (0xAAAAAAAA, 0xBBBBBBBB, 0xCCCCCCCC, 0xDDDDDDDD)
MACHINE_CHECK_EXCEPTION
*** STOP: 0x00000024 (0xAAAAAAAA, 0xBBBBBBBB, 0xCCCCCCCC, 0xDDDDDDDD)
NTFS_FILE_SYSTEM
*** STOP: 0x0000000A (0xAAAAAAAA, 0xBBBBBBBB, 0xCCCCCCCC, 0xDDDDDDDD)
IRQL_NOT_LESS_OR_EQUAL
Note The four parameters in these error messages vary, depending on the memory location where the Stop error occurs.

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Cause

This problem occurs if a host bus adapter is installed that uses a memory address range that extends beyond the 32-bit boundary.

Note The 32-bit boundary is also known as the 4-gigabyte (GB) boundary.

A host bus adapter device that supports scatter-gather DMA may incorrectly wrap back to the beginning of a 4-GB memory segment and, in this way, corrupt that memory location. This problem occurs because the Windows hardware abstraction layer (HAL) may incorrectly give the device a scatter-gather element that crosses a 4-GB boundary.

The Windows IA-64 HAL is supposed to break up scatter-gather list elements so that they do not cross 4-GB boundaries. However, the IA-64 HAL breaks up these scatter-gather elements only when they cross 8-GB boundaries. A scatter-gather element that crosses a 4-GB boundary causes one of the following behaviors to occur:
  • The host bus adapter driver and the host bus adapter handle the scatter-gather element correctly, and the 64-bit DMA across the boundary works correctly.
  • A host bus adapter that uses a fixed 32-bit base and a variable 32-bit offset wraps back to the beginning of the starting 4-GB segment, and this causes silent data corruption.
  • A host bus adapter that uses a fixed 32-bit base and a variable 32-bit offset wraps back to the beginning of the starting 4-GB segment. However, in this scenario, the adapter references a target memory address that is not referenced by an actual memory location. Therefore, a Stop error occurs.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer to apply the changes after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   09-Apr-2004  16:34  5.2.3790.159      305,664  Hal.dll          IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbdiskmemory, kbfilesystems, kberrmsg, kbbug, kbfix, kbwinserv2003presp1fix, kbqfe, kbhotfixserver, kbhardware, KB840551

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Article Info
Article ID : 840551
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 328