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The MTA Stacks service may not start on computers that are running Exchange 2000 Server Service Pack 2 (SP2) or later service packs, or Exchange Server 2003


View products that this article applies to.

Symptoms

The MTA Stacks service may not start on computers that are running one of the following products:
  • Microsoft Exchange 2000 Server Service Pack 2 (SP2) or later service packs
  • Microsoft Exchange Server 2003
  • Microsoft Exchange Server 2003 Service Pack 1 (SP1) or later service packs
Additionally, Microsoft Outlook clients that connect to the computer that is running Exchange 2000 Server or Exchange Server 2003 may have outgoing e-mail messages in the Outbox that cannot be sent.

Additionally, event messages that resemble the following messages may be logged in the Application log:

Event Type: Warning
Event Source: MSExchangeMTA
Event Category: Resource
Event ID: 9406
Description:
There is not enough Performance Monitor memory to display the MTA Connections information. Stop attached Performance Monitors and re-start the MTA. [BASE MAIN BASE 1] (14)

Event Type: Warning
Event Source: MSExchangeMTA
Event Category: Field Engineering
Event ID: 2219
Description:
The MTA is running recovery on the internal message database because the MTA was not shut down cleanly. This operation may take some time. Status updates will be written to the Windows 2000 Event Log. [DB Server MAIN BASE 1 0] (14)

Event Type: Warning
Event Source: MSExchangeMTA
Event Category: Field Engineering
Event ID: 2206
Description:
The MTA database recovery operation is now checking queue: XAPIWRKQ, the filename of this queue is: 01000020. [DB Server MAIN BASE 1 29] (14)

Event Type: Warning
Event Source: MSExchangeMTA
Event Category: Field Engineering
Event ID: 2207
Description:
The MTA database recovery operation has completed successfully. Recovery details can be found in the file: C:\Program Files\Exchsrvr\mtadata\.\MTACHECK.OUT\MTACHECK.LOG. [DB Server MAIN BASE 1 67] (14)

Event Type: Error
Event Source: MSExchangeMTA
Event Category: Field Engineering
Event ID: 9405
Description:
An unexpected error has occurred which may cause the MTA to terminate. Error: Init Routing API returned error -2147219168. [BASE MAIN BASE 1] (16)

Event Type: Error
Event Source: MSExchangeMTA
Event Category: Directory Access
Event ID: 137
Description:
A fatal directory error occurred. Change to the maximum logging level for more details. [MTA MAIN BASE 1 12] (16)

The following related events may also appear in the Application log:

Event Type: Error
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Event ID: 326
Description:
Service Account failed to logon to the store as /o=Informa/ou=First Administrative Group/cn=Configuration/cn=Connections/cn=SMTP (THETA)/cn={0E2F8576-678B-429F-883B-343E22545246}. Error code : 0x80040148.

Event Type: Error
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Event ID: 324
Description:
Instance 1 failed to initialize. Error code : 0x80040148.

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Cause

This problem typically occurs when the SMTP protocol is corrupted or is missing.

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Resolution

To resolve this problem, remove and then reinstall the SMTP protocol on the computer that is running Exchange 2000 Server or Exchange Server 2003. To do this, follow these steps.

Step 1: Remove the SMTP protocol

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Add or Remove Programs.
  3. In the Add or Remove Programs dialog box, click Add/Remove Windows Components.
  4. In the Add/Remove Windows Components dialog box, click Internet Information Services (IIS), and then click Details.
  5. In the Internet Information Services (IIS) details box, click to clear the SMTP Service check box, and then click OK.
  6. Click Next two times.
  7. Click Finish.
  8. Restart the computer that is running Exchange 2000 Server or Exchange Server 2003.

Step 2: Reinstall the SMTP protocol

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps. When you reinstall the SMTP protocol, complete the steps under the sub-section "Exchange 2000 Server and Exchange Server 2003." Then, complete the steps under the "Exchange 2000 Server" sub-section or the "Exchange Server 2003" sub-section, as appropriate for the version of Exchange that you are running.

Exchange 2000 Server and Exchange Server 2003

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Add or Remove Programs.
  3. In the Add or Remove Programs dialog box, click Add/Remove Windows Components.
  4. In the Add/Remove Windows Components dialog box, click Internet Information Services (IIS), and then click Details.
  5. In the Internet Information Services (IIS) Details dialog box, click to select the Add the SMTP Service check box, and then click OK.
  6. Click Next two times.
  7. Click Finish.
  8. Restart the computer.

Exchange 2000 Server

  1. Copy the Smtpreinstall.exe file from the Support\utils\i386 folder that is on the Exchange 2000 Server Service Pack CD or the Exchange 2000 Server Service Pack share. Copy this file to the Exchsrvr\Bin folder on the computer that is running Exchange 2000 Server.
  2. Run the Smtpreinstall.exe file from the Exchsrvr\Bin folder on the computer that is running Exchange 2000 Server.
  3. Click OK. The Microsoft Exchange SMTP Reinstall message box indicates that SMTP was successfully configured on the computer that is running Exchange 2000 Server.
  4. Manually restart the computer that is running Exchange 2000 Server.

Exchange Server 2003

After you reinstall the SMTP protocol, you might be unable to send or to receive e-mail by using the affected server. If this situation occurs, you must reinstall Exchange Server 2003. To do this, follow these steps:
  1. Make sure that the SMTP service is installed.
  2. Insert the Exchange Server 2003 CD in the CD drive or DVD drive, and then double-click Drive:\Setup\I386\Setup.exe.

    Note Drive is the name of the drive that contains the Exchange Server 2003 CD.
  3. In the installation wizard, click Next.
  4. In the Action column, click reinstall for each installed component, click Next, and then follow the instructions to complete the installation wizard.
  5. Reapply all Exchange Server 2003 service packs and hotfixes.

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Keywords: KB840469, kbprb

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Article Info
Article ID : 840469
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 243