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Data does not decompress when you use behaviors with compressed data in Internet Explorer 6


Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

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Symptoms

When you use behaviors to download information from a file to an HTML document, and Static Compression is turned on in Microsoft Internet Information Services (IIS), the data that is downloaded to the HTML document does not always appear. Typically, the document loads as expected on the first attempt. However, dynamic data may not appear when you try to download it again.

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Cause

This problem occurs because Microsoft Internet Explorer always reads compressed data as being cached, even if the cache-control setting specifies a different value.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   16-Apr-2004  01:58  6.0.2800.1421  485,888  Urlmon.dll       
   16-Apr-2004  01:59  6.0.2800.1421  589,824  Wininet.dll
				

Installation information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you install this hotfix, follow these steps:
  1. Quit Internet Explorer.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_TEMPORARYFILES_FOR_NOCACHE_840387
  5. Click Edit, point to New, and then click DWORD Value.
  6. Type Iexplore.exe, and then press ENTER.
  7. Right-click Iexplore.exe, and then click Modify.
  8. In the Value data box, type 00000001, and then click OK.
  9. On the File menu, click Exit to quit Registry Editor.

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Workaround

To work around this behavior for dynamic HTML (DHTML) functionality, turn off Static Compression on IIS for maximum compatibility.

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Status

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

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References

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
255801� How to determine if HTTP compression is in use
For more information about how to develop Web-based solutions for Microsoft Internet Explorer, visit the following Microsoft Web sites:

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Keywords: KB840388, kbbug, kbfix, kbie600presp2fix, kbie600sp2fix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 840388
Revision : 5
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 100