Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Your USB keyboard may not work correctly with a 64-bit version of Windows Server 2003


View products that this article applies to.

Symptoms

When you attach a universal serial bus (USB) keyboard to your computer that is running a 64-bit version of Microsoft Windows Server 2003, the USB keyboard may not be detected and the USB keyboard may not work correctly. After you restart your computer, this symptom may occur occasionally. If you view the properties of your USB keyboard in Device Manager, you may receive the following error message:
The device driver can not be loaded because the previous instance of this hardware�s device driver is still in memory. (Code 38).

↑ Back to the top


Cause

This problem is caused by a conflict that may occur when Windows Server 2003 loads the USB driver for the keyboard.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name     Platform
   -------------------------------------------------------------------
   16-Apr-2004  17:17  5.2.3790.163  5,605,888  Ntkrnlmp.exe  IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB840213, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 840213
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 256