Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a "You do not have exclusive access to the database at this time. If you proceed to make changes, you may not be able to save them later." error message when you try to open database objects in Access


View products that this article applies to.

Symptoms

When you open a Microsoft Access database object, such as a form, a report, a macro, or a module in Design view, you may receive the following error message:
You do not have exclusive access to the database at this time. If you proceed to make changes, you may not be able to save them later.
This error message occurs even if there is only one user in the database.

↑ Back to the top


Cause

If the database file and the workgroup information file have the same name and are located in the same folder, two record-locking information files (.ldb) are created when an Access object is opened. This causes the error message that is mentioned in the "Symptoms" section.

Note By default, the record-locking information file is created with the same file name as the workgroup information file. The record-locking information file is also created in the same folder as the workgroup information file. The record-locking information file has an .ldb file name extension.

↑ Back to the top


Workaround

To work around this problem, use one of the following methods:
  • Rename the database file to make sure that only one .ldb file is in the folder that contains the database file and the workgroup information file.
  • Move the database file to another folder.
  • Open the database exclusively.

↑ Back to the top


More information

Steps to reproduce the problem

Create a new workgroup information file for your Microsoft Access 2000 database

To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Run dialog box, type Full path of Wrkgadm.exe in the Open box.

    Note By default, the Wrkgadm.exe file is located in the C:\Program Files\Microsoft Office\Office\1033 folder.
  3. In the Workgroup Administrator dialog box, click Create.
  4. In the Workgroup Owner Information dialog box, type Northwind in the Name box, and then type 5 in the Workgroup ID box.
  5. Click OK.
  6. In the Workgroup Information File dialog box, type the location that you want to save the file to, and then click OK.
  7. In the Confirm Workgroup Information dialog box, click OK.
  8. In the Workgroup Administrator dialog box, click OK.

Create a new workgroup information file for your Microsoft Access 2002 database and for your Microsoft Office Access 2003 database

To do this, follow these steps:
  1. Start Access 2002 or Access 2003.
  2. Open the Northwind.mdb sample database.
  3. On the Tools menu, point to Security, and then click Workgroup Administrator.
  4. In the Workgroup Administrator dialog box, click Create.
  5. In the Workgroup Owner Information dialog box, type Northwind in the Name box, and then type 5 in the Workgroup ID box.
  6. Click OK.
  7. In the Workgroup Information File dialog box, type the folder location of the database file. In the Workgroup box, type the file name Northwind.mdw, and then click OK.

    Note Make sure that the Workgroup Information file has the same file name and the same folder location as the database file.
  8. In the Confirm Workgroup Information dialog box, click OK.
  9. Close Access 2002 or Access 2003.
  10. Join the newly-created workgroup information file that you created in steps 1 through 8.
  11. Start Access 2002 or Access 2003.
  12. Open the Northwind.mdb sample database.
  13. Open an Access database object, such as a form, a report, a macro, or a module.

    You may receive the error message that is mentioned in the "Symptoms" section.
When you open an Access database, if both the database file (.mdb) and the workgroup information file (.mdw) have the same name, a record-locking information file (.ldb) is created for the .mdw file and an entry that indicates that the database file is open is added to the .ldb file. After the .mdb file is opened, Access detects an .ldb file with the same name as the .mdb file in the same folder, and therefore adds another entry to the .ldb file. The entries in the .ldb file now indicate that there are two users in the database. Therefore, when you open a database object, such as a report in Design view, Access may detect two active connections in the .ldb file. This may cause the error message that is mentioned in the "Symptoms" section. This error message indicates that the user does not have exclusive access to the database.

If you open the database, close the database without closing Access, and then you open the database again exclusively, you may be able to view the database object in Design view. When you open the database the first time, the .mdw file is accessed, and therefore the .ldb file is created. Two active-connection entries are written to the .ldb file. One active-connection entry is for the .mdw file, and the other active-connection entry is for the .mdb file. When you close the database, the second active-connection entry in the .ldb file may be removed or may be modified to indicate that the user is no longer connected. Subsequently, when you open the database exclusively, Access may not create an .ldb file or may not write an entry to the .ldb file because Access detects only one active entry in the .ldb file. You can open a report in Design view because Access detects only one user in the database.

↑ Back to the top


References

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
225938 "You do not have exclusive access..." message appears more than once when editing module
200290 Exclusive lock required for saving design changes to Access objects
305541 Understanding the role of workgroup information files in Access security

↑ Back to the top


Keywords: KB839782, kbprb, kberrmsg, kbdatabase, kbsecurity

↑ Back to the top

Article Info
Article ID : 839782
Revision : 2
Created on : 9/17/2011
Published on : 9/17/2011
Exists online : False
Views : 385