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You receive an error when you try to expand the public store folder by using Exchange System Manager in Exchange 2003


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Symptoms

When you try to expand the public folder store by using Exchange System Manager on a computer that is running Microsoft Exchange Server 2003, you may receive an error message that is similar to the following:
An internal server error has occurred on the server. The requested operation failed.
ID no: c1030af2
Additionally, when you try to view the properties of a public store folder, you may receive an error message that is similar to the following:
The operation failed because of an http error 501 (not implemented). Verify that the exadmin virtual root exists on the destination server.
ID no: c1030af7

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Cause

This problem may occur when the Exadmin virtual server is not working correctly.

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Resolution

To resolve this problem, you must re-create the Exadmin virtual server in Internet Information Services (IIS). To re-create the Exadmin virtual server, back up the IIS metabase, remove the Exadmin virtual directory, remove the directory-service-to-metabase-replication component (Ds2mb.dll), and then restart the System Attendant service.
  1. To back up the IIS metabase, follow these steps:
    1. Start Internet Information Services Manager.
    2. Right-click the server object, point to All tasks, and then click Backup/Restore Configuration.
    3. In the Configuration Backup/Restore dialog box, click Create Backup.
    4. In the Configuration backup dialog box, type the name of the backup file in the Configuration backup name box, and then click OK.

      Your backup is added to the Previous backups list in the Configuration Backup/Restore dialog box.
    5. Click Close to return to the Internet Information Services Manager main window.
  2. To remove the Exadmin virtual directory, right-click the Exadmin object in Internet Information Services Manager, and then click Delete.
  3. To delete the directory-service-to-metabase-replication component in the metabase, follow these steps:
    1. Start a command prompt, and then change to the drive:\Inetpub\Adminscripts directory.
    2. Type
      cscript adsutil.vbs delete ds2mb
      and then press ENTER.
  4. In Services, restart the Worldwide Web Publishing Service and the System Attendant service.

    Restarting the System Attendant service restarts the Microsoft Exchange Information Store service, restarts the message transfer agent (MTA) stacks, and re-creates the Exadmin virtual directory.

    Note To open Services, click Start, point to Settings, click Control Panel, and then double-click Administrative Tools.
In Internet Information Services Manager, verify that the Exadmin virtual directory has been re-created. Open Exchange System Manager, and then verify that you can access and administer the public folders.

If you continue to receive error messages when you access the public folders, follow these steps:
  1. Start Internet Information Services Manager.
  2. Right-click the Exadmin object, and then click Properties.
  3. On the General tab in the local path text box, type \\backofficestorage to replace the existing \\BackOfficeStorage text.
  4. Click OK to close the Properties box.

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Keywords: KB839744, kberrmsg, kbprb

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Article Info
Article ID : 839744
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 274