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Group Policy setting that prevents use of the Internet Connection Firewall is not enforced in Windows XP or in Windows Server 2003 with SP1


View products that this article applies to.

Symptoms

When your Group Policy setting prevents the use of the Internet Connection Firewall (ICF) in Microsoft Windows XP or in Microsoft Windows Server 2003 with Service Pack 1 (SP1), the Netman.dll file may not enforce that policy.

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Cause

This problem may occur when a registry subkey value is null. If you use Group Policy slow link detection and set the connection speed to zero, the following subkey may be null:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\History\NetworkName

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Resolution

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Apr-2004  06:42  5.1.2600.1513     675,840  Userenv.dll      x86
   06-Apr-2004  06:35  5.1.2600.1513   1,714,176  Userenv.dll      IA-64

STATUS

This problem was first corrected in Microsoft Windows XP Service Pack 2.

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Service Pack 1 installed to install this hotfix..
Restart requirement
You must restart your computer after install this hotfix
Hotfix replacement information
This hotfix does not replace any other hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Windowsserver2003-kb839551-x86-enu.exe1.0.0.0716,52817-Aug-200515:40x86NoneNot Applicable
Userenv.dll5.2.3790.2510790,01617-Aug-200515:12x86SP1SP1QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Userenv.dll5.2.3790.25101,069,56817-Aug-200515:34x64SP1SP1QFE
Wuserenv.dll5.2.3790.2510790,01617-Aug-200515:34x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Windowsserver2003-kb839551-ia64-enu.exe1.0.0.01,562,35217-Aug-200515:39x86NoneNot Applicable
Userenv.dll5.2.3790.25101,564,67217-Aug-200515:34IA-64SP1SP1QFE
Wuserenv.dll5.2.3790.2510790,01617-Aug-200515:34x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbwinxpsp2fix, kbwinxppresp2fix, kbfix, kbbug, kbwinserv2003sp2fix, KB839551

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Article Info
Article ID : 839551
Revision : 9
Created on : 3/27/2007
Published on : 3/27/2007
Exists online : False
Views : 253