Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

No SQL performance counters appear in the counter log file after you save them in Windows Server 2003 System Monitor


View products that this article applies to.

Symptoms

After you save SQL performance counters as a counter log file (a .blg file) in Microsoft Windows Server 2003 System Monitor and then open the counter log file in System Monitor, no SQL performance counters appear. An event message that is similar to the following is logged in the system event log for each SQL performance counter that was not saved in the counter log file:

Event Type: Warning
Event Source: SysmonLog
Event Category: None
Event ID: 2028
Date: 3/2/2004
Time: 6:58:28 AM
User: N/A
Computer: ComputerName
Description: The service was unable to add the counter '\\ComputerName\CounterName' to the log or alert. This log or alert will continue, but data for that counter will not be collected. The error returned is: The specified object is not found on the system.

For more information, see Help and Support Center at http://support.microsoft.com.

Note In this event message, ComputerName is a placeholder for the actual computer name, and CounterName is a placeholder for the actual counter name.

↑ Back to the top


Cause

This problem occurs because, by default, the Performance Logs and Alerts service runs under the Network Service account in Windows Server 2003, but the Network Service account may not have permissions to save the SQL performance counters in a trace file.

↑ Back to the top


Resolution

To resolve this problem, change the Performance Logs and Alerts service account to use the Local System account. To do this, follow these steps:
  1. Click Start, point to Programs, click Administrative Tools, and then click Services.
  2. In Services, right-click Performance Logs and Alerts, and then click Properties.
  3. In the Performance Logs and Alerts Properties Service (Local Computer) dialog box, click the Log On tab.
  4. Click Local System account under Log on as, and then click OK.

↑ Back to the top


More information

This problem typically affects only SQL Server performance counters. This problem does not occur with system performance counters such as the following:
  • Memory
  • Network Interface
  • Paging File
  • PhysicalDisk
  • Process
  • Processor
  • Thread

↑ Back to the top


Keywords: KB839506, kbprb

↑ Back to the top

Article Info
Article ID : 839506
Revision : 4
Created on : 10/30/2006
Published on : 10/30/2006
Exists online : False
Views : 191