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A System State backup operation is unsuccessful when it tries to back up custom event log nodes in Windows Server 2003


View products that this article applies to.

Symptoms

When you try to back up the System State information on your Microsoft Windows Server 2003-based computer, the backup operation is unsuccessful. The backup operation fails when it tries to back up custom event log nodes that you have created.

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Cause

This problem occurs if both the following conditions are true:
  • You back up the System State information by using a backup program that does not support the Windows volume shadow copy functionality.
  • The custom event log nodes have names that are 12 or more characters in length.
When you create a custom event log node, an .evt extension is appended to the name of that node. However, if the node name is more than 8 characters long, the file name extension is truncated so that the complete file name is not more than 12 characters. If the file name is 12 characters or longer, the .evt extension is not added. In this scenario, when the file does not have a file name extension, the backup program considers the file to be a registry hive file and tries to back it up by using a different method than it uses for event log files. Therefore, the backup operation is unsuccessful.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart your computer to apply the changes after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Feb-2004  22:20  5.2.3790.1154     158,208  Eventlog.dll   

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

After you install this hotfix, the following changes occur in Windows:
  • When you create a new custom event log node by creating a new registry key under
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EventLog
    the new log file is created with an .evt file name extension in the %SystemRoot%System32\Config folder. For example, if you create a custom event log named "My Custom Log", the new log file is named, "My Custom Log.evt". On a computer where this hotfix is not installed, the new log file would be named "My Custom Lo".
  • When the Event Log service creates a new event log, the registry value File is correctly created and populated to point to the correct file.
  • If a log file was created before you apply this hotfix, and if that log file already has a File registry value, the Event Log service does not change it. This behavior is by design, because the File value might have been intentionally created as a user preference. Typical event logs always specify the File registry value while the Setup program is running.
  • If a log file was created before you apply this hotfix, and if that log file does not already have a File registry value, a new file with an .evt file name extension is created when you next restart the computer. For example, if you have a custom event log that is named "My Custom Log", and if that custom event log has no File value in the registry, when you restart the computer, the Event Log service leaves the "My Custom Lo" log file on the hard disk and creates a new "My Custom Log.evt" file. In this scenario, the new file is used to log events. However, the earlier events remain in the previous log file in the %SystemRoot%System32\Config folder.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbbackup, kbeventlog, kbbug, kbfix, kbwinserv2003presp1fix, kbqfe, KB839207

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Article Info
Article ID : 839207
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 271