Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an "A Microsoft Distributed Transaction Coordinator problem prevented connection to the Configuration database" error message when you publish assemblies from BizTalk Server 2004


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

↑ Back to the top


Symptoms

When you work with a Microsoft BizTalk Server 2004 project on a Microsoft Windows Server 2003-based computer, and you deploy the assemblies to BizTalk Server 2004, you may receive the following error message from Microsoft Visual Studio .NET:
[Microsoft.BizTalk.Deployment.DeploymentException] Cannot open database BizTalkMgmtDb on server [server]. [Microsoft.BizTalk.Deployment.DeploymentException] Cannot open database BizTalkMgmtDb on server [server]. A Microsoft Distributed Transaction Coordinator problem prevented connection to the Configuration database. The transaction has already been implicitly or explicitly committed or aborted
Note In this error message, [server] is a placeholder for the computer that is running Microsoft SQL Server and that houses the BizTalk Management database.

The deployment wizard log file may contain the following log entries:
A Microsoft Distributed Transaction Coordinator problem prevented connection to the Configuration database. The transaction has already been implicitly or explicitly committed or aborted
[Microsoft.BizTalk.Deployment.DeploymentException] Cannot open database BizTalkMgmtDb on server [server].
[Microsoft.BizTalk.Deployment.DeploymentException] Cannot open database BizTalkMgmtDb on server[server].
Command failed with 3 errors and 0 warnings. All actions have been undone and no changes have been made.

↑ Back to the top


Cause

This behavior occurs because Remote Procedure Call (RPC) security requires that the computer that is running SQL Server 2000 and the BizTalk Server 2004 computer exist in the same Active Directory domain. RPC security is used for Data Transaction Coordinator (DTC) authentication between BizTalk 2004 computers.

↑ Back to the top


Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

You may also experience this problem after you install Microsoft Windows Server 2003 Service Pack 2 (SP2) or Windows Server 2003 Service Pack 1 (SP1). To work around this problem, turn off RPC security on the computers that are running Windows Server 2003.

Windows Server 2003

To turn off RPC security on a computer that is running Windows Server 2003 without any service packs installed, set the DWORD value of the TurnOffRpcSecurity registry value to 1. To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC\TurnOffRpcSecurity
    Note If this subkey does not exist, create this subkey.
  3. On the Edit menu, click Modify.
  4. In the Value data box, type 1, and then click OK.
  5. Exit Registry Editor.

Windows Server 2003 SP1 and later service packs

To turn off RPC security on a computer that is running Windows Server 2003 SP1 or a later service pack, follow these steps:
  1. Click Start, click Run, type dcomcnfg in the Open box, and then click OK.
  2. Expand Component Services, expand Computers, right-click My Computer, and then click Properties.
  3. In the My Computer Properties dialog box, click the MSDTC tab, and then click Security Configuration.
  4. In the Security Configuration dialog box, click to select the Allow Remote Clients check box. Then click No Authentication Required under Transaction Manager Communications.
  5. Click OK, and then click Yes to restart the MS DTC service.
  6. After the service has restarted, click OK.
  7. Click OK to close the My Computer Properties dialog box.
  8. Restart the server.

↑ Back to the top


More information

RPC security is a new MS DTC feature in Windows Server 2003. When you disable RPC security, the MS DTC authentication security level for RPC calls goes back to a security level that is available in Microsoft Windows 2000 Server. For more information about the new MS DTC functionality in Windows 2003 Service Pack 1 and in later service packs, click the following article number to view the article in the Microsoft Knowledge Base:
899191� New functionality in the Distributed Transaction Coordinator service in Windows Server 2003 Service Pack 1 and in Windows XP Service Pack 2
For more information about BizTalk Server 2004 and SQL Server 2000 in separate domains, click the following article number to view the article in the Microsoft Knowledge Base:
827805� BUG: MSDTC fails to mutually authenticate when computers do not run in the same domain

↑ Back to the top


Keywords: KB839187, kbbtsorchestration, kbbug, kbnofix

↑ Back to the top

Article Info
Article ID : 839187
Revision : 5
Created on : 8/9/2007
Published on : 8/9/2007
Exists online : False
Views : 576