Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Network Load Balancing servers are removed from the Internet Group Management Protocol membership list in Windows Server 2003


View products that this article applies to.

Symptoms

A computer that is a Network Load Balancing server and that is running Microsoft Windows Server 2003 and the Internet Group Management Protocol (IGMP) may not respond to IGMP queries from some multicast routers. This behavior may cause the Network Load Balancing server to be removed from the IGMP membership list.

↑ Back to the top


Cause

This problem occurs because Network Load Balancing IGMP report messages are not synchronized with host membership queries from the router or from the switch. The IGMP stack that is used by the Network Load Balancing client is hard-coded to send a report message every 60 seconds. IEEE RFC 1112 specifies that the client software must respond to IGMP membership queries after a randomly selected delay that is not greater than 10 seconds. However, the Network Load Balancing report messages are not synchronized with the IGMP membership queries in Windows Server 2003. This scenario causes the router or the switch to drop the Network Load Balancing client from the membership list.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-May-2004  16:50  5.2.3790.170      381,952  Wlbs.sys

Windows Server 2003, 32-bit editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-May-2004  20:00  5.2.3790.170      169,984  Wlbs.sys

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Workaround

To work around this problem, do not use IGMP. To avoid using IGMP, configure Virtual Local Area Networks (VLANs) to isolate Network Load Balancing traffic to a subset of ports on the switch. If you use this workaround, you must reconfigure both the switch and the Network Load Balancing nodes from IGMP multicast mode to unicast mode.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
193602� Configuration options for WLBS hosts connected to layer 2 switches

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbclustering, kbserver, kbnetwork, kbwinserv2003presp1fix, kbhardware, kbinterop, kbfix, kbbug, kbautohotfix, KB838408

↑ Back to the top

Article Info
Article ID : 838408
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 389