Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Desktop application menus are improperly displayed if a process exceeds its GDI object quota in Windows XP or in Windows 2000


View products that this article applies to.

Symptoms

Application menus and context menus are improperly displayed for other applications when a process exceeds its graphics device interface (GDI) object quota. (The default object quota is 10,000.) The problem persists even after the process exits and is especially noticeable with three-dimensional (3-D) menus and with shadowing.

Note After the process exceeds its GDI object quota, the process may display more than just menus incorrectly. The process may also inadvertently write over the Windows desktop. You must exit the process before you try to address these problems.

↑ Back to the top


Cause

When an application exceeds its GDI object quota, the application can no longer allocate GDI objects. However, in this scenario, the application continues to operate as if it can allocate objects and starts painting objects on the screen incorrectly. An additional effect of this behavior is that the operating system menus do not handle the situation correctly. Menus for other applications are also affected.

↑ Back to the top


Resolution

To regain the correct Windows desktop display, use one of the following methods:

Method 1

  1. Exit the application that exceeded the GDI object quota.
  2. Press CTRL+ALT+DELETE or press Windows logo key+L to switch to the logon window.
  3. Click Cancel if you are logged on to a domain, or click your user name to return your desktop.

Method 2

  1. Exit the application that exceeded the GDI object quota.
  2. Right-click the task bar, and then click Show the Desktop.
  3. Start an application, such as Internet Explorer, and then switch to the full-screen display by pressing F11.

Microsoft Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
There are no prerequisites to install this hotfix.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   02-Apr-2004  14:05  5.1.2600.1502  1,797,120  Win32k.sys
   09-Jan-2004  21:11  5.4.1.0          140,800  Spuninst.exe
   09-Jan-2004  14:46  5.4.1.0            6,656  Spmsg.dll

Microsoft Windows 2000

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must be running Microsoft Windows 2000 Service Pack 3 (SP3) or later to install this hotfix. For more information about how to obtain the latest Windows 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version           Size    File name
   ----------------------------------------------------------
   23-Mar-2004  15:17  5.0.2195.6892     90,264  Rdpwd.sys
   05-Apr-2004  23:25  5.0.2195.6922  1,630,640  Win32k.sys
   23-Mar-2004  18:17  5.0.2195.6897    742,160  Kernel32.dll
   23-Mar-2004  18:17  5.0.2195.6898    242,448  Gdi32.dll
   05-Apr-2004  09:26  5.4.15.0           6,656  Spmsg.dll
   05-Aug-2003  14:14  5.0.2195.6794    385,808  Userenv.dll
   10-Mar-2004  18:37  5.0.2195.6898    181,520  Winlogon.exe
   23-Mar-2004  18:17  5.0.2195.6824     42,256  Basesrv.dll
   05-Feb-2004  12:18  5.0.2195.6896  5,869,056  Sp3res.dll
   23-Mar-2004  18:17  5.0.2195.6897    403,216  User32.dll
   23-Mar-2004  18:17  5.0.2195.6895    335,120  Msgina.dll
   15-Nov-2001  15:27                     5,149  Empty.cat
   05-Apr-2004  09:27  5.4.15.0         158,208  Spuninst.exe
   23-Mar-2004  18:17  5.0.2195.6824     54,544  Mpr.dll
   20-Sep-2003  16:45  5.0.2195.6824    236,304  Cmd.exe
   25-Sep-2003  10:08  5.0.2195.6826    243,984  Winsrv.dll 


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP This problem was first corrected in Microsoft Windows XP Service Pack 2.

↑ Back to the top


More information

You can use Windows Task Manager to monitor the GDI objects of a process. To do this:
  1. Start Windows Task Manager.
  2. Click View, click Select Columns, and then click the GDI Objects button.
You can also monitor the GDI objects with the Gdiobj.exe tool. To obtain this tool, visit the following Web site:
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Note This problem was first corrected in Microsoft Windows Server 2003 Service Pack 1 (SP1). The information in this article also applies to Microsoft Windows Server 2003, Standard Edition (32-bit x86) and Microsoft Windows Server 2003, Enterprise Edition (32-bit x86).

↑ Back to the top


Keywords: kbautohotfix, kbwinxpsp2fix, kbwinxppresp2fix, kbfix, kbbug, kbqfe, kbhotfixserver, KB838283

↑ Back to the top

Article Info
Article ID : 838283
Revision : 7
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 357