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Error messages occur when you modify objects in Active Directory in Windows Server 2003


View products that this article applies to.

Symptoms

When you try to access or modify objects in Active Directory directory service, you may receive one of the following error messages:
Insufficient system resources exist to complete the requested service
Windows cannot set the password for <useraccount>. Insufficient system resources exist to complete the requested service.
The system cannot log you on due to the following error: Insufficient system resources exist to complete the requested service.

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Cause

This problem occurs when the number of concurrent connections to the Security Account Manager (SAM) exceeds the limit of 1024. When this limit is reached, a Microsoft Windows Server 2003-based domain controller returns the "ERROR_NO_SYSTEM_RESOURCES" error message, and you receive one of the error messages that are mentioned in the "Symptoms" section. You can view the "ERROR_NO_SYSTEM_RESOURCES" error message with a network trace.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   -----------------------------------------------------
   10-Mar-2004  09:45  5.2.3790.139  464,384  Samsrv.dll


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This hotfix increases the maximum number of concurrent connections to the SAM from 1024 to 2048.

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References

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbqfe, kbfix, kbbug, kbwinservnetwork, kbautohotfix, KB838184

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Article Info
Article ID : 838184
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 224