Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

No option in Windows Server 2003 to set the Extended Key Usage (EKU) extension to use a "Critical" setting


View products that this article applies to.

Symptoms

If your Microsoft Windows Server 2003-based computer is configured as a certification authority (CA), you may find that there is no option in the Certification Authority snap-in to set the Extended Key Usage (EKU) extension to use a "Critical" setting.

↑ Back to the top


Cause

This problem occurs because there is no option in Windows Server 2003 to configure the pkIExtendedKeyUsage attribute in Active Directory to use a "Critical" setting.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version        Size    File name
-------------------------------------------------------
05-Mar-2004  21:04  5.2.3790.138  244,736  Certtmpl.dll

Windows Server 2003, 64-Bit Edition

Date         Time   Version        Size    File name
-------------------------------------------------------------
05-Mar-2004  21:06  5.2.3790.138  748,544  Certtmpl.dll  IA-64
05-Mar-2004  21:04  5.2.3790.138  244,736  Wcerttmpl.dll x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB838165, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 838165
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 305