Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you migrate computer accounts, primary group membership is in the Domain Users group in Windows Server 2003


View products that this article applies to.

Symptoms

When you use the Active Directory Migration Tool Version 2 to migrate several computers into an organizational unit, primary group membership is in the Domain Users group instead of in the Domain Computers group.

↑ Back to the top


Cause

This problem occurs if your account has been delegated permissions to create computer objects in an organizational unit, and your account does not have permissions to add or to remove members from the Domain Users group or from the Domain Computers group.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Mar-2004  20:03  5.2.3790.137      536,576  Mcsdctworkerobjectsnt4.dll  

Windows Server 2003, 64-Bit Edition

   Date         Time   Version            Size    File name                   Platform
   -----------------------------------------------------------------------------------
   03-Mar-2004  19:34  5.2.3790.137    1,753,600  Mcsdctworkerobjectsnt4.dll  IA-64
To install this hotfix, copy Mcsdctworkerobjectsnt4.dll to NT4Agent\Mcsdctworkerobjects.dll under the folder that contains the Active Directory Migration Tool (ADMT). By default, the folder is C:\Program Files\Active Directory Migration Tool.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB838164

↑ Back to the top

Article Info
Article ID : 838164
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 344