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Several orphaned Csrss.exe processes cause performance issues on a terminal server that is running Windows 2000 or Windows Server 2003


View products that this article applies to.

Symptoms

On your Microsoft Windows 2000 Server-based computer or your Microsoft Windows Server 2003-based computer that is running Terminal Services, you may experience the following symptoms:
  • The server becomes slow and unresponsive. Eventually, you cannot establish new Terminal Services sessions.
  • If you use Task Manager to view the running processes, you may see that there are several orphaned Csrss.exe processes. There are no corresponding Terminal Services client sessions when you view the sessions in Terminal Services Manager.
  • You cannot stop the orphaned Csrss.exe processes to free server resources. Therefore, the Csrss.exe processes may continue to accumulate until you must restart the server to free memory and CPU resources.
If you apply the hotfix that is described in the Microsoft Knowledge Base article 827350, this may help reduce the number of Csrss.exe processes, but you still experience the problem.
827350� Clients cannot connect to a terminal server when Csrss.exe and Termsrv.exe spike at 100 percent CPU usage

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Cause

The problem occurs because of a regression that was introduced in Windows 2000 Service Pack 3 (SP3). Windows 2000 SP3 includes a fix that introduces a temporary winstation object in the Csrss.exe process. This fix is described in the following Microsoft Knowledge Base article:
261322� Stop 0x0000001E error message when you print from a Windows 2000 Terminal Services client
If the temporary winstation objects are not released correctly, you may experience the symptoms that are described earlier in this article.

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Resolution

Hotfix information

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.170291,84004-May-200423:28x86

Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.170764,92804-May-200408:22IA-64

Windows 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows 2000 Service Pack 3 (SP3) installed on the computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Basesrv.dll5.0.2195.682442,25624-Mar-200402:17x86Not Applicable
Cmd.exe5.0.2195.6824236,30421-Sep-200300:45x86Not Applicable
Gdi32.dll5.0.2195.6660233,74419-Jun-200320:05x86Not Applicable
Kernel32.dll5.0.2195.6897742,16024-Mar-200402:17x86Not Applicable
Mpr.dll5.0.2195.682454,54424-Mar-200402:17x86Not Applicable
Msgina.dll5.0.2195.6958335,12013-Jul-200421:25x86Not Applicable
Rdpwd.sys5.0.2195.689290,26424-Mar-200402:17x86Not Applicable
Sp3res.dll5.0.2195.69355,887,48804-Jun-200423:13x86Not Applicable
User32.dll5.0.2195.6897403,21624-Mar-200402:17x86Not Applicable
Userenv.dll5.0.2195.6794385,80805-Aug-200322:14x86Not Applicable
Win32k.sys5.0.2195.69581,631,76010-Jul-200405:36x86Not Applicable
Winlogon.exe5.0.2195.6898181,52011-Mar-200402:37x86Not Applicable
Winsrv.dll5.0.2195.6958244,49613-Jul-200421:25x86Not Applicable
Kernel32.dll5.0.2195.6897742,16024-Mar-200402:17x86UNIPROC
Win32k.sys5.0.2195.69581,631,76010-Jul-200405:36x86UNIPROC
Winsrv.dll5.0.2195.6958244,49613-Jul-200421:25x86UNIPROC

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This feature was first included in Windows Server 2003 Service Pack 1.

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More information

For more information about how hotfix packages are named, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915� New naming schema for Microsoft Windows hotfix packages
824684� Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbhotfixserver, kbbug, kbfix, kbqfe, kbwin2000presp5fix, KB837585

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Article Info
Article ID : 837585
Revision : 8
Created on : 11/3/2007
Published on : 11/3/2007
Exists online : False
Views : 532