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Users may receive a "503 Service Unavailable" error message in Exchange Server 2003 when they try to use a Web browser to gain access to OWA


View products that this article applies to.

Symptoms

When users try to use a Web browser to gain access to Microsoft Office Outlook Web Access for Exchange Server 2003, they may receive the following error message:
503 Service Unavailable

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Cause

This issue may occur when the following conditions are true:
  • The Exchange 2003 computer is upgraded from Microsoft Windows 2000 to Microsoft Windows Server 2003.
  • The Microsoft Data Access Components (MDAC) file that is named Oledb32.dll is not upgraded to the correct version during the Windows Server 2003 upgrade.
In this scenario, the Microsoft Exchange Information Store service may not start because the file version of Oledb32.dll is incorrect.

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Resolution

To resolve this issue, copy Oledb32.dll from a Windows Server 2003-based computer that was not upgraded from Windows 2000, and then restart the Microsoft Exchange Information Store service. To do this, follow these steps:
  1. Click Start, point to All Programs, point to Administrative Tools, and then click Services.
  2. Stop the Microsoft Exchange Information Store service.
  3. Copy the Oledb32.dll file from a Windows Server 2003-based computer that was not upgraded from Windows 2000 to your Exchange computer. To do this, use one of the following methods.

    Method 1

    Copy the file from an available Windows Server 2003-based computer that was not upgraded from Windows 2000.

    Method 2

    1. Install a new copy of Windows Server 2003 to a separate partition on the computer by creating a parallel installation.
    2. Copy the Oledb32.dll file.
    3. Remove the new installation, if you want.
    For additional information about how to create a parallel installation, click the following article number to view the article in the Microsoft Knowledge Base:
    266465 How to perform a parallel installation of Windows 2000 or Windows 2003
    Note The default location of Oledb32.dll is C:\Program Files\Common Files\System\OLE DB\Oledb32.dll.
  4. Copy Oledb32.dll to the same location on the Exchange computer where you are trying to resolve this issue.
  5. On the Exchange computer, type the following commands at the command prompt:
    • cd Program Files\Common Files\System\ole db
    • regsvr32 oledb32.dll

    Note The Oledb32.dll file version must be 2.8.1022.0 or later to resolve the issue that is described in the "Symptoms" section.
  6. Start the Microsoft Exchange Information Store service.

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More information

When you experience the issue that is described in the "Symptoms" section, the following events may be logged in the application event log when you restart the Exchange 2003 services:

Event Type: Information
Event Source: MSExchangeSA
Event Category: General
Event ID: 9014
Description: Microsoft Exchange System Attendant has been started for Exchange server servername successfully.


Event Type: Information
Event Source: MSExchangeSA
Event Category: Monitoring
Event ID: 9095
Description: The MAD Monitoring thread is initializing.


Event Type: Information
Event Source: MSExchangeSA
Event Category: Monitoring
Event ID: 9096
Description: The MAD Monitoring thread is initialized.


Event Type: Information
Event Source: EXOLEDB
Event ID: 101
Description: Microsoft Exchange OLEDB has successfully shutdown.


Event Type: Error
Event Source: MSExchangeIS
Event ID: 9542
Description: Initialization of external interface OLEDB failed; Error ecServerOOM.



Additionally, the following event ID message may be logged in the application event log multiple times:

Event Type: Error
Event Source: EXCDO
Event Category: General
Event ID: 8206
Description: Calendaring agent failed with error code 0x800XXXXX while saving appointment.



The following event ID error message may be logged in the System Log in the Event Viewer multiple times:

Event Type: Error
Event Source: DCOM
Event Category: None
Event ID: 10002
Description: Access denied attempting to launch a DCOM Server. The server is: {9DA0E106-86CE-11D1-8699-00C04FB98036} The user is SYSTEM/NT AUTHORITY, SID=S-1-5-18


For additional information about troubleshooting the "503 Service Unavailable" error message, click the following article number to view the article in the Microsoft Knowledge Base:
823159 How to troubleshoot the "503 Service Unavailable" error message in Outlook Web Access in Exchange Server 2003

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Keywords: KB837285, kberrmsg

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Article Info
Article ID : 837285
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 224