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Security event 681 is generated when you try to log on by using UPN credentials in Windows XP or in Windows 2000


View products that this article applies to.

Symptoms

When your user principal name (UPN) credentials use the LogonUser function to log on to a Microsoft Windows XP, a Microsoft Windows 2000 or a Microsoft Windows Server 2003-based computer that is a member of a domain, the logon operation may not work on the first try. And although logon eventually succeeds, the following event is logged in the security event log:

Event ID 681
The logon to account: testuser@domain.com by: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0 from workstation: ComputerName failed.
The error code was: 3221225572

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Cause

This issue occurs when the Windows XP, the Windows Server 2003, or the Windows 2000-based computer tries to validate the UPN domain account locally instead of first directing it to the domain. This behavior generates the misleading event 681 error code.

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Resolution

Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll      
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll       
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll     
   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll     
   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll       
   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll     
   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys
   11-Mar-2004  02:37  5.0.2195.6902     520,976  Lsasrv.dll       
   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe        
   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll       
   24-Mar-2004  02:17  5.0.2195.6897     312,592  Netapi32.dll     
   06-Apr-2004  22:03  5.0.2195.6920     361,744  Netlogon.dll     
   24-Mar-2004  02:17  5.0.2195.6896   1,028,880  Ntdsa.dll        
   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll       
   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll       
   05-Feb-2004  20:18  5.0.2195.6896   5,869,056  Sp3res.dll       
   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll      
   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe        

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP 32-bit version

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   25-Feb-2004  19:27  5.1.2600.1353     400,896  Netlogon.dll   

Windows XP 64-bit version

   Date         Time   Version            Size    File name
   ---------------------------------------------------------------------
   25-Feb-2004  19:24  5.1.2600.1353   1,047,040  Netlogon.dll     IA-64
   25-Feb-2004  19:27  5.1.2600.1353     400,896  Wnetlogon.dll    x86

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 32-bit version

File nameFile versionFile sizeDateTimePlatform
Netlogon.dll5.2.3790.3090426,49614-Feb-200813:52x86
Netlogon.dll5.2.3790.4236437,24814-Feb-200814:21x86

Windows Server 2003 64-bit version

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Netlogon.dll5.2.3790.3090689,66414-Feb-200813:06x64SP1Not Applicable
Wnetlogon.dll5.2.3790.3090426,49614-Feb-200813:06x86SP1WOW
Netlogon.dll5.2.3790.4236689,66414-Feb-200813:11x64SP2Not Applicable
Wnetlogon.dll5.2.3790.4236437,24814-Feb-200813:11x86SP2WOW

Windows Server 2003 IA-64 version

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Netlogon.dll5.2.3790.3090989,69614-Feb-200813:06IA-64SP1Not Applicable
Wnetlogon.dll5.2.3790.3090426,49614-Feb-200813:06x86SP1WOW
Netlogon.dll5.2.3790.4236989,69614-Feb-200813:11IA-64SP2Not Applicable
Wnetlogon.dll5.2.3790.4236437,24814-Feb-200813:11x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about software update packages, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about event 681 errors, click the following article number to view the article in the Microsoft Knowledge Base:
273499 Description of security event 681

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Keywords: kbautohotfix, kbhotfixserver, kbbug, kbfix, kbqfe, kbwin2000presp5fix, KB837142

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Article Info
Article ID : 837142
Revision : 6
Created on : 2/25/2008
Published on : 2/25/2008
Exists online : False
Views : 343