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Performance Monitor stops responding on Windows Server 2003-based computers that have more than 40 logical disks


View products that this article applies to.

Symptoms

When you try to gather performance data on a computer that is running Microsoft Windows Server 2003, you may experience increased memory consumption. The disk performance counters may show consumption of as much as 2 gigabytes (GB) of memory, and the performance monitoring program may stop responding. Also, some performance objects, such as the Logical Disk object and the Physical Disk object, may disappear from the performance counter monitor.

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Cause

This problem may occur on computers that have 40 or more logical disks.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Feb-2004  00:59  5.2.3790.132       55,808  Perfdisk.dll     IA-64
   24-Feb-2004  01:00  5.2.3790.132       25,600  Wperfdisk.dll    x86
   20-Jan-2004  01:53                        271  Branches.inf
   24-Feb-2004  01:06                     10,119  Kb837126.cat
   24-Feb-2004  01:02                        354  Updatebr.inf
   24-Feb-2004  01:02                      6,540  Update_rtmqfe.inf
x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Feb-2004  01:00  5.2.3790.132       25,600  Perfdisk.dll     
   20-Jan-2004  01:54                        271  Branches.inf
   24-Feb-2004  01:06                      9,766  Kb837126.cat
   24-Feb-2004  01:01                        354  Updatebr.inf
   24-Feb-2004  01:01                      6,265  Update_rtmqfe.inf

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbwinserv2003presp1fix, kbmemory, kbperformance, kbinterop, kbmisctools, kbqfe, kbfix, kbbug, kbqfe, KB837126

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Article Info
Article ID : 837126
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 287