Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive access violation messages and the DNS service stops on a DNS server that is running Windows 2000 or Windows Server 2003


View products that this article applies to.

Symptoms

On a DNS Server that is running Microsoft Windows 2000 Server or Microsoft Windows Server 2003 and that is configured to load zone information from a file, you may receive frequent access violation messages. The DNS service may stop on the server. When this problem occurs, you must restart the DNS service.

A sample TXT record in the text-based zone file will look similar to the following:

@ TXT ( "Just some Text \303\204\303\204\303\204\303\204\303\204\303\204\303\204" )
victim TXT ( "please do not overwrite me \303\204\303\204\303\226\303\226\303\234\303\274\303\274\303\266\303\266\303\266\303\266\303\266 1234 564" )
tester.victim A 10.10.10.10


Additionally, one of the following errors may be logged in the application event log:

Windows Server 2003

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: 14.11.2003
Time: 10:03:08
User: N/A
Computer: Server Name
Description: Faulting application dns.exe, version 5.2.3790.100, faulting module ntdll.dll, version 5.2.3790.0, fault address 0x00003847.

For more information, see Help and Support Center at http://support.microsoft.com.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 64 6e 73 ure dns
0018: 2e 65 78 65 20 35 2e 32 .exe 5.2
0020: 2e 33 37 39 30 2e 31 30 .3790.10
0028: 30 20 69 6e 20 6e 74 64 0 in ntd
0030: 6c 6c 2e 64 6c 6c 20 35 ll.dll 5
0038: 2e 32 2e 33 37 39 30 2e .2.3790.
0040: 30 20 61 74 20 6f 66 66 0 at off
0048: 73 65 74 20 30 30 30 30 set 0000
0050: 33 38 34 37 3847



Event Type: Information
Event Source: Application Error
Event Category: (100)
Event ID: 1004
Date: 14.11.2003
Time: 11:07:28
User: N/A
Computer: Server Name
Description: Reporting queued error: faulting application dns.exe, version 5.2.3790.100, faulting module ntdll.dll, version 5.2.3790.0, fault address 0x00003847.

For more information, see Help and Support Center at http://support.microsoft.com.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 64 6e 73 ure dns
0018: 2e 65 78 65 20 35 2e 32 .exe 5.2
0020: 2e 33 37 39 30 2e 31 30 .3790.10
0028: 30 20 69 6e 20 6e 74 64 0 in ntd
0030: 6c 6c 2e 64 6c 6c 20 35 ll.dll 5
0038: 2e 32 2e 33 37 39 30 2e .2.3790.
0040: 30 20 61 74 20 6f 66 66 0 at off
0048: 73 65 74 20 30 30 30 30 set 0000
0050: 33 38 34 37 3847



Windows 2000 Server

Event Type: Information


Event Source: DrWatson
Event Category: None
Event ID: 4097
User: N/A
Computer: Server Name
Description:The application, dns.exe, generated an application error The error occurred on 03/15/2004 @ 12:40:39.922 The exception generated was 80000003 at address 77FA144B (DbgBreakPoint)
Data:
0000: 0d 0a 0d 0a 41 70 70 6c ....Appl
0008: 69 63 61 74 69 6f 6e 20 ication
0010: 65 78 63 65 70 74 69 6f exceptio
0018: 6e 20 6f 63 63 75 72 72 n occurr
0020: 65 64 3a 0d 0a 20 20 20 ed:..
0028: 20 20 20 20 20 41 70 70 App
0030: 3a 20 64 6e 73 2e 65 78 : dns.ex
0038: 65 20 28 70 69 64 3d 31 e (pid=1
0040: 34 38 38 29 0d 0a 20 20 488)..

↑ Back to the top


Cause

This problem may occur if a DNS TXT record contains non-ASCII characters. These characters are saved in octal escaped form to the zone file.

↑ Back to the top


Resolution

Hotfix information

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Dns.exe5.2.3790.1381,023,48805-Mar-200405:09IA-64RTMQFE
Wdns.exe5.2.3790.138422,91205-Mar-200405:26x86WOW

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Windowsserver2003-kb837088-x86-enu-symbols.exe5.4.1.0148,72005-Mar-200405:42x86Not Applicable
Windowsserver2003-kb837088-x86-enu.exe5.4.1.0482,03205-Mar-200405:42x86Not Applicable
Dns.exe5.2.3790.138422,91205-Mar-200405:26x86RTMQFE

Windows 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows 2000 Service Pack 3 (SP3) installed to apply the hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dns.exe5.0.2195.6902327,44025-Feb-200407:33x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinservnetwork, kbnetwork, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbhotfixserver, KB837088

↑ Back to the top

Article Info
Article ID : 837088
Revision : 11
Created on : 11/4/2007
Published on : 11/4/2007
Exists online : False
Views : 442