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You receive an error message when you set the permissions of a public folder in an Exchange Server 2003 mailbox


View products that this article applies to.

Symptoms

When you use Microsoft Outlook to set the permissions of a public folder in a Microsoft Exchange Server 2003 mailbox, you receive an error message that is similar to the following:
The modified permissions cannot be saved. The client operation failed.
When you use Exchange System Manager to set the permissions of a public folder in an Exchange 2003 mailbox, you receive an error message that is similar to the following:
Invalid Windows handle. ID no. 80040102

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Cause

This problem may occur if the following conditions are true:
  • You changed the access control lists (ACLs) by using PFDavAdmin, RewriteACL, or another program that uses XML to write permissions to public folders.
  • You added the role of Reviewer to the public folders.
If you use XML to write permissions to public folders, the ACLs may become out of canonical order. This problem may occur although the XML is correctly formatted. Additionally, this problem occurs when the following contexts have the same access mask and are written and evaluated at the same time:
  • Effective
  • Container
  • Subitem
These three contexts have the same access mask when an individual user account has its permissions set as Reviewer.

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Resolution

Cumulative update information

To resolve this problem, install Microsoft Exchange Server 2003 Service Pack 1 (SP1). For more information about Exchange 2003 SP1, click the following article number to view the article in the Microsoft Knowledge Base:
836993� How to obtain the latest service packs for Exchange Server 2003

Hotfix information

Alternatively, apply the following hotfix to resolve this problem. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date         Time    Version       Size        File name
   ------------------------------------------------------------
   26-Feb-2004   12:19   6.5.6980.72     373,248   Exsmtp.dll       
   26-Feb-2004   10:20   6.5.6980.72      49,152   Mdbevent.dll     
   26-Feb-2004   11:00   6.5.6980.72   3,190,272   Mdbmsg.dll       
   26-Feb-2004   10:22   6.5.6980.72      24,064   Mdbrole.dll      
   26-Feb-2004   11:48   6.5.6980.72      13,312   Mdbtask.dll      
   26-Feb-2004   11:45   6.5.6980.72   5,045,760   Store.exe        

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� New naming schema for Exchange Server software update packages

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Keywords: kbautohotfix, kbqfe, kbqfe, kbfix, kbbug, kbexchange2003presp1fix, kbpubtypekc, kbhotfixserver, KB836897

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Article Info
Article ID : 836897
Revision : 8
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 291