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The Plug and Play hardware-detection operation stops responding after you plug an ATAPI device into your Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you plug an ATAPI device, such as a CD-ROM drive, into your Microsoft Windows Server 2003-based computer, the device may not be detected as expected. Additionally, the Plug and Play hardware-detection operation stops responding (hangs) in this scenario.

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Cause

This problem occurs because the Atapi.sys component in Windows Server 2003 may not respond to a Plug and Play request on some fault-tolerant computer systems. In certain instances, the IdaPortScanBus() function may not correctly process a request to the Plug and Play device queue. Therefore, Windows Server 2003 may no longer process Plug and Play device requests.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

32-bit versions of Windows Server 2003

   Date         Time   Version            Size    File name
   --------------------------------------------------------
   30-Mar-2004  18:13  5.2.3790.146       91,136  Atapi.sys

Windows Server 2003 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------
   30-Mar-2004  18:13  5.2.3790.146      288,256  Atapi.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB836871

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Article Info
Article ID : 836871
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 351