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Windows Server 2003 does not import an LMHOSTS record that includes a quoted string of 15 characters plus the NetBIOS suffix after the IP address


View products that this article applies to.

Symptoms

When you use the Windows Internet Name Service (WINS) Manager Microsoft Management Console (MMC) to import an LMHOSTS file on a computer that is running Microsoft Windows Server 2003, no error is reported in the WINS Manager MMC. However, the computer does not successfully import an LMHOSTS record if the following conditions are true:
  • The LMHOSTS record contains an IP address at the beginning of the record.
  • The LMHOSTS record contains a quoted string of 15 characters plus the NetBIOS suffix characters.
For example, the following LMHOSTS record is not imported successfully:
xxx.xxx.xxx.xxx "15 character NETBIOS name/0x1B"
.

Additionally, if you perform an NetBT query and you import an LMHOSTS file that contains any "as-is" name to a WINS database on a Windows Server 2003 Datacenter Edition-based computer, you may receive the following error message:
Name doesn't exist

(An "as-is" name is a name in quotation marks.)

For example, if you run the following query
1.1.1.1 "AA"
you can import the LMHOSTS file, but subsequent queries for this quoted name are unsuccessful.

For additional information about LMHOSTS and other name resolution issues, click the following article numbers to view the articles in the Microsoft Knowledge Base:
180094� How to write an LMHOSTS file for domain validation and other name resolution issues
163409� NetBIOS suffixes (16th character of the NetBIOS name)
When you experience this symptom, WINS records Event 4299 in the System event log. The entry may be similar to the following entry:

Event Type: Error
Event Source: Wins
Event Category: None
Event ID: 4299
Description: The following name, "MYDOMAIN \0x1b", is too long. Valid NetBios names must not exceed 15 characters. The name has not been entered in the WINS database.

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Cause

This problem occurs because Windows Server 2003 Datacenter Edition has changed the way WINS parses the LMHOSTS file.

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Resolution

To work around this issue, you can use the Netsh.exe command-line tool to manually add group names and unique names instead of using the Import function in WINS. To use this method, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At a command prompt, type netsh.
  3. At the netsh prompt, type wins server \\x.x.x.x, where \\x.x.x.x is the IP address of the WINS server.
  4. At the netsh wins server prompt, type add name Name=MyDomainName endchar=1b IP=IP address, where MyDomainName is the name of the domain, and IP address is the IP address of the primary domain controller in the domain.

    For example, at the c:\>netsh wins server prompt, type add name Name=MyDomain endchar=1b IP={10.1.1.1}.
.

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Status

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   08-Mar-2004  17:19  5.2.3790.139      144,384  Wins.exe         x86
   08-Mar-2004  16:29  5.2.3790.139      467,968  Wins.exe         IA-64

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More information

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbqfe, kbwinservnetwork, kbnetwork, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbhotfixserver, KB836773

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Article Info
Article ID : 836773
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 353