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Telnet sessions do not receive the escape character


View products that this article applies to.

Symptoms

If a Telnet client connects with a terminal type other than NTVT terminal type, escape characters are not received by applications that are running in a Telnet session. For example, escape characters are not received if a Telnet client connects with a terminal that is VT52 type, VT100 type, or ANSI type.

Note This problem does not occur with Telnet clients that support the NTVT terminal type. Windows Telnet clients work as expected.

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Cause

The escape character is passed to the Telnet session as an enhanced key. However, because the escape character is not an enhanced key, it is not considered to be valid and is discarded.

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Resolution

Service pack information

Windows XP

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Collapse this tableExpand this table
DateTimeVersionSizeFile name
08-Mar-200419:388.0.1969.3142,848Tlntsess.exe
10-Mar-200402:068,798Tlntsvr.cat
08-Mar-200419:388.0.1969.3166,400Tlntsvr.exe
08-Mar-200419:38978Tlntsvr.inf
08-Mar-200419:388.0.1969.314,336Tlntsvrp.dll

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Workaround

For Windows Telnet clients, you can use the following command to set the terminal type to VTNT:
telnet -t vtnt
For more information, see the Telnet Client documentation.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows XP Service Pack 2.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbqfe, kbfix, kbbug, KB836529

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Article Info
Article ID : 836529
Revision : 9
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 308