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An e-mail message may not be formatted correctly when an Exchange Server 2003 mailbox user sends an e-mail message to an external user


View products that this article applies to.

Symptoms

When a Microsoft Exchange Server 2003 mailbox user sends an e-mail message to an external user, the e-mail message may not be formatted correctly.

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Cause

This problem may occur when the following conditions are true: �
  • The e-mail message is relayed by a smart host from one Exchange computer to another.
  • The e-mail message contains a line of text that has more than 998 characters.
  • The Exchange Server 2003 computer uses 7-bit encoding to send messages in MIME format.
  • One of the following character sets or code pages is used to compose the e-mail message: ISO-2022-KR, ISO-2022-JP, csISO2022JP, or UTF-7.
This problem occurs when some Asian character sets are used to compose an e-mail message, and the message is sent in MIME format by using 7-bit encoding. The problem occurs because the lines in the text that are longer than 998 characters cannot be wrapped, and the characters are labeled with incorrect 7-bit encoding during transport to the final mailbox server.

The default MIME encoding in Exchange Server 2003 is 7-bit transfer encoding. The MIME encoding in some Asian languages must be set to an encoding method that is different from 7-bit encoding. The lines of text that contain more than 998 characters can then be wrapped.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

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More information

After you apply this hotfix, you can use registry values to set the MIME encoding method in the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\TransferEncodingFor7bit
The hotfix that resolves this issue lets an administrator use the registry to select the transfer encoding for all the character sets that are affected. The administrator must set the encoding method correctly based on the clients and their encoding capability.

Use the appropriate value from the following table to control the MIME encoding behavior.
ValueBehavior
0Always use 7-bit encoding for both HTML and plain text.
1Always use quoted-printable encoding for both HTML and plain text.
2Always use Base64 encoding for both HTML and plain text.
5Use quoted-printable encoding for HTML and plain text. If plain-text line wrapping is enabled, use quoted-printable encoding for HTML, and use 7-bit encoding for plain text.
6Use Base64 encoding for HTML and plain text. If plain-text line wrapping is enabled, use Base64 encoding for HTML, and use 7-bit encoding for plain text.
13 (=0x0D)Always use quoted-printable encoding for HTML, and always use 7-bit encoding for plain text.
14 (=0x0E)Always use Base64 encoding for HTML, and always use 7-bit encoding for plain text.
Exchange uses the default value of zero for 7-bit encoding if the registry subkey value contains a value that is not listed in this article, or if a value is not present. After you change the value of the TransferEncodingFor7bit subkey, you must stop and then restart the Microsoft Exchange Information Store service on the Exchange 2003 computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Exchange Server 2003 Service Pack 2.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB835992, kbexchange2003presp1fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 835992
Revision : 5
Created on : 1/14/2011
Published on : 1/14/2011
Exists online : False
Views : 283