Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BUG: List of currently linked tables may not appear in Linked Table Manager Wizard in a database in Access 2003


View products that this article applies to.

This article applies only to a Microsoft Access database (.mdb).

Moderate: Requires basic macro, coding, and interoperability skills.
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you start Linked Table Manager Wizard in a Microsoft Office Access 2003 database that contains linked tables, you may notice that the list of currently linked tables, together with their paths, does not appear in the Select the linked tables to be updated list box. Therefore, you may not be able to update the linked tables.

↑ Back to the top


Cause

This problem may occur for either of the following reasons:
  • The Accwiz.dll file that is used by Access 2003 is not registered correctly on your computer.
  • The version of the Accwiz.dll file that is used by Access 2003 and is registered on your computer may be an incorrect version.

↑ Back to the top


Resolution

To resolve this problem, you must locate and then register the correct version of the Accwiz.dll file. To do this, follow these steps:
  1. Locate the Accwiz.dll file on your computer that corresponds to Access 2003. To do this, follow these steps:
    1. Search for all copies of the Accwiz.dll file on your computer.
    2. For each copy of the Accwiz.dll file that is listed in the search results, right-click the Accwiz.dll file, and then click Properties.
    3. In the ACCWIZ.DLL Properties dialog box, notice the version number that is mentioned for File Version on the Version tab.

      For example, if the version number is similar to 11.x.xxxx.x, the Accwiz.dll file corresponds to Access 2003.
  2. At the command prompt, run the following command:
    regsvr32.exe <path>\Accwiz.dll
    Note In this step, <path> is a placeholder. Make sure that the <path> placeholder is replaced by the full path of the Accwiz.dll file that you located in step 1.
If the previous method does not resolve this problem, examine the following registry value data to see if the value data is pointing to the correct Accwiz.dll file in Access 2003.
HKCR\TypeLib\{5B87B6F0-17C8-11D0-AD41-00A0C90DC8D9}\8.0\0\win32\<(Default)>
where (Default) is the following registry key value:
C:\Program Files\Microsoft Office\OFFICE11\ACCWIZ.DLL.

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

You may see the problem that is mentioned in the "Symptoms" section when you install an earlier version of Access on a computer that has Access 2003 already installed.

Steps to reproduce the problem

  1. On a computer that has Access 2003 already installed, install Access 2002.
  2. Start Access 2003.
  3. Open the Northwind.mdb sample database.
  4. Create a linked table in the Northwind.mdb sample database.
  5. On the Tools menu, point to Database Utilities, and then click Linked Table Manager.

    You may notice that the list of the currently linked tables does not appear in the Select the linked tables to be updated list box.

↑ Back to the top


Keywords: KB835519, kbdll, kbwizard

↑ Back to the top

Article Info
Article ID : 835519
Revision : 6
Created on : 9/17/2011
Published on : 9/17/2011
Exists online : False
Views : 398