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CPU usage hits 100 percent if the system is low on memory and the Server for NFS service is running


Symptoms

When available memory is almost exhausted, the CPU utilization reaches 100 percent and stays at 100 percent until the available memory increases. This behavior only occurs when the Server for NFS service is running. The behavior may occur regardless of whether the system has exported any network file system (NFS) shares.

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Cause

Server for NFS tries to free memory in its internal caches when it encounters a low memory situation. This action can help make the low memory condition less severe and can help improve system performance and stability. However, the NFS driver searches constantly for memory to free until the system is no longer in a low memory situation, and in the process it completely uses the CPU.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.


Date Time Version Size File name
---------------------------------------------------
20-Jan-2004 23:52 7.1.2239.4 423,168 Nfssvr.sys

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Workaround

If you are not using Server for NFS, you can stop the Server for NFS service until the hotfix is applied. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type command, and then click OK.
  3. At the command prompt, type net stop nfssvc, and then press ENTER.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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[Asset 4020123]

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbbug, kb

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Article Info
Article ID : 835152
Revision : 4
Created on : 4/17/2018
Published on : 4/19/2018
Exists online : False
Views : 157