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Windows Server 2003 logs Event ID 51 although no data has been lost from the hard disk


View products that this article applies to.

Symptoms

When you have a hard disk storage array that is configured in your Microsoft Windows Server 2003-based computer, Event ID 51 may appear many times in the system log in Event Viewer with a description that is similar to the following:

Event Source: Disk
Event Category: None
Event ID: 51
Date: date
Time: time
Type: Warning
User: N/A
Computer: computername
Description: An error was detected on device \Device\Harddisk7 during a paging operation. For more information, see Help and Support Center at http://support.microsoft.com.
Data:



These events may occur when when you add or remove a hard disk device from a Storage Area Network (SAN) array to Windows Server 2003. This hard disk device is also known as a Logical Unit Number (LUN).

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Cause

This problem occurs if an Input/Output (I/O) operation to a hard disk is unsuccessful. When an I/O operation to a hard disk is unsuccessful, Windows Server 2003 logs Event ID 51 in the system log. This problem occurs even if the I/O operation is retried and is subsequently successful.

When you add or remove a new LUN from a NAS array to Windows Server 2003, Windows may log Event ID 51. This event appears even if the I/O operation was successful after a retry. In Windows versions that are earlier than Windows Server 2003, these operations do not cause Event ID 51 messages.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You may have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jan-2004  02:12  5.2.3790.123       61,952  Classpnp.sys
Microsoft Windows Server 2003, 64-Bit Enterprise Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jan-2004  01:20  5.2.3790.123      145,408  Classpnp.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

After you install this hotfix, Windows logs Event ID 51 only if an I/O request is unsuccessful after all the subsequent retry operations have completed.

Event ID 51 typically appears in the system log if an I/O operation to a hard disk is unsuccessful. In this scenario, troubleshoot the hard disk subsystem to determine the cause of the error. Windows Server 2003 also logs vendor-defined unit attention operations. Event ID 51 may also appear when you add a new LUN to Windows Server 2003. When all the connected LUNs are performing I/O operations, unit attention that is generated on those LUNs causes the generation of Event ID 51 events when you add a new LUN. In this case, the I/O operation is retried successfully, and no additional troubleshooting is required. This problem does not occur in Microsoft Windows 2000.

For additional information about Event ID 51, click the following article number to view the article in the Microsoft Knowledge Base:
244780 Information about Event ID 51

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB834910

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Article Info
Article ID : 834910
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 340