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"HTTP 403 (Forbidden)" error message when Exchange 2003 users try to use Outlook Web Access to access a freedoc that is located in a public folder


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Symptoms

When a Microsoft Exchange Server 2003 user tries to use Microsoft Outlook Web Access (OWA) to access a freedoc that is located in a public folder, the user may receive the following error message:
HTTP 403 (Forbidden)
You are not authorized to view this page.

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Cause

This behavior occurs because Exchange 2003 does not permit you to use OWA to directly access freedocs that are stored in public folders. By default, Exchange Server 2003 prevents direct access to freedocs that are stored in public folders. When you are permitted to open freedocs that are stored in public folders, you may receive unexpected results. Freedocs might contain executable script that runs on the user's computer.

When a user tries to access freedocs in public folders, the user receives the error message that is described in the "Symptoms" section. Although freedocs that are stored in public folders cannot be accessed, freedocs that are stored in mailbox folders can be accessed if the user has the proper permission to the freedoc.

Microsoft recommends that you use these folders when access to freedocs is required. Alternatively, if you determine that freedoc access in an uncontrolled public folder is an acceptable risk, you can enable access to freedocs in public folders. You enable access to freedocs in public folders by modifying the registry of the Exchange Server 2003 back-end server where the public folders are located.

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Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows


To change the default behavior to permit an OWA user to access freedocs in public folders, follow these steps on both front-end and back-end servers:
  1. Start Registry Editor.

    To do this, click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeWeb\OWA
  3. On the Edit menu, point to New, click DWORD Value, and then type EnableFreedocs.
  4. Double-click EnableFreedocs, and then set the value to one of the following:

    0 = Freedocs are inaccessible in OWA. This value is the default value.
    1 = Freedocs are accessible in OWA, but only when the freedocs are accessed from the back-end server.
    2 = Freedocs are accessible in OWA, but only when the freedocs are accessed from the back-end server or the front-end server by using a host header that matches an entry in the
    AcceptedAttachmentFrontEnds
    registry value.
    3 = Freedocs are accessible everywhere.

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Status

This behavior is by design.

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More information

A freedoc is any document in the Exchange mailbox store that has a message class that starts with IPM.Document. For example, a Microsoft Word document that has been saved directly in the mailbox or the public store is a freedoc. Such a document generally has a message class of IPM.Document.*doc.

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Keywords: KB834743, kbprb, kberrmsg, kbexchangeowa

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Article Info
Article ID : 834743
Revision : 8
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 278