Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Certificate Services ignores the HighSerial registry entry after the first restart in Windows Server 2003


View products that this article applies to.

Symptoms

When you set the HighSerial registry entry value to change the length of the serial number that is assigned to certificates that the certification authority issues, Certificate Services must restart for the change to take effect. However, on subsequent restarts, the serial number has the default size.

↑ Back to the top


Cause

This problem occurs because the certificate server checks the HighSerial registry entry only on the first restart after the registry entry is changed. The certificate server does not check the HighSerial registry entry on subsequent restarts. Therefore, the certificate server uses the default serial number length on subsequent restarts.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   08-Jan-2004  20:19  5.2.3790.116  294,912  Certsrv.exe   
Windows Server 2003, 64-Bit Enterprise Edition
   Date         Time   Version       Size     File name  
   ------------------------------------------------------
   07-Jan-2004  17:41  5.2.3790.116  877,056  Certsrv.exe

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbfix, kbbug, kbautohotfix, kbqfe, kbhotfixserver, kbwinserv2003presp1fix, kbcertservices, KB834389

↑ Back to the top

Article Info
Article ID : 834389
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 1465