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CPU usage in the Indexing Service increases to 100 percent in Windows XP and in Windows Server 2003


View products that this article applies to.

Symptoms

On a Microsoft Windows XP-based or Microsoft Windows Server 2003-based computer that uses a removable memory storage device, you may find that, in certain situations, CPU usage in the Indexing Service (Cisvc.exe) increases to 100 percent.

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Cause

This problem may occur if both the following conditions are true:
  • The removable memory storage device slot is empty and does not contain a removable memory storage device.
  • The Indexing Service is started.
In this situation, the Plug and Play (PNP) component generates mount notifications, and a nonpaged pool memory leak may occur.

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Resolution

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP
Date         Time   Version        Size       File name
--------------------------------------------------------
19-Dec-2003  18:32  5.1.2600.1330  1,350,144  Query.dll  
Windows XP 64-Bit Edition
Date         Time   Version         Size       File name
---------------------------------------------------------------
19-Dec-2003  18:37  5.1.2600.1330   4,942,336  Query.dll   IA-64
19-Dec-2003  18:32  5.1.2600.1330   1,350,144  Wquery.dll  x86
Note This hotfix requires Windows XP Service Pack 1.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbwinxpsp2fix, kbqfe, kbwinxppresp2fix, kbfix, kbbug, kbautohotfix, KB833228

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Article Info
Article ID : 833228
Revision : 8
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 273