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The WMI Event Log provider takes a long time to notify the WMI subscriber when multiple event logs are written to an event log file


View products that this article applies to.

Symptoms

The Microsoft Windows Management Instrumentation (WMI) Event Log provider may take longer than expected to notify the WMI subscriber when multiple event logs are written to an event log file.

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Cause

This problem may occur if both of the following conditions are true:
  • More than one event log change occurs within a five-second interval.
  • An event is logged to another log file less than one minute after the first log change.
The WMI Event Log provider relies on the NotifyChangeEventLog function to receive a notification when an event is written to a specified event log file. If more than one event log change occurs within a five-second interval, only one notification is received by the NTEventLog provider.

This limitation occurs because the system calls the PulseEvent function no more frequently than one time every five seconds. Therefore, even if more than one event log change occurs within a five-second interval, you will receive only one notification.

For more information about the NotifyChangeEventLog function, visit the following MSDN Web site: To bypass this limitation and to retrieve the other events, the WMI Event Log provider has a polling mechanism to wake up and to poll "all unread" events "every minute" (0xea60 = 60000ms=1minute). The WMI Event Log provider then delivers the unread events to the event subscriber. If two or more events are created in one event log file within a five-second interval, the first event will be read immediately, and the other events will be delivered later within the poll interval (the maximum delay is one minute).

However, if a new event is logged to a different log file during the one-minute delay, the delivery of the unread events to the first log file may be delayed even longer. This long delay occurs because the unread events are not written to the first log file until one of the following conditions is true:
  • A new event is logged to the first event log file.
  • There are not any new events logged to any other log file for at least one minute since the last event was logged to any log file.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit version
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-Nov-2003  19:35  5.2.3790.106       64,000  Eventlog.dll     
   16-Nov-2004  23:38                        271  Branches.inf
   19-Nov-2004  23:42                      9,766  Kb833010.cat
   26-Nov-2003  19:38                        354  Updatebr.inf
   26-Nov-2003  19:38                      5,654  Update_rtmqfe.inf
Windows Server 2003 64-bit version
   Date         Time   Version            Size    File name	     Platform
   --------------------------------------------------------------------------
   26-Nov-2003  19:30  5.2.3790.106      167,424  Eventlog.dll       IA-64
   25-Oct-2003  00:13                        271  Branches.inf
   26-Nov-2003  19:44                      9,628  Kb833010.cat
   26-Nov-2003  19:39                        354  Updatebr.inf
   26-Nov-2003  19:39                      5,674  Update_rtmqfe.inf

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB833010

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Article Info
Article ID : 833010
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 317