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Terminal Services stops responding on your Windows Server 2003 server


View products that this article applies to.

Symptoms

After Terminal Services has run for three or four days on your Microsoft Windows Server 2003-based computer, the following symptoms may occur:
  • Terminal Services stops responding (hangs).
  • You cannot log off any open Terminal Services sessions.
  • You cannot log on at the console of the Terminal Services computer.
  • You cannot log on to a Terminal Services session from another computer. When you try to log on to a Terminal Services session from another computer, the Winlogon process starts, the session stops responding, and the session screen becomes blank.
  • Your computer becomes sluggish, and eventually stops responding (hangs).
You must restart Windows Server 2003 to recover from this problem.

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Cause

This problem may occur if a Terminal Services session has not shut down completely. This problem may occur even if the problem session has been logged off the Terminal server. A session may not shut down completely if a process in the session is waiting for the redirector to process a shadow I/O Request Package (IRP). The process that is waiting for the redirector prevents a program from closing, and the session cannot shut down until the program closes.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time     Version         Size      File name   Platform
------------------------------------------------------------------
25-Nov-2003  22:28    5.2.3790.105    394,752   Mrxsmb.sys  x86
25-Nov-2003  22:28    5.2.3790.105    157,696   Rdbss.sys   x86
Date         Time     Version        Size       File name   Platform
--------------------------------------------------------------------
25-Nov-2003  22:32    5.2.3790.105  1,121,792   Mrxsmb.sys  IA-64
25-Nov-2003  22:32    5.2.3790.105    463,872   Rdbss.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB832971

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Article Info
Article ID : 832971
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 304