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Clients cannot log on to domain controllers that are Windows Server 2003-based DNS servers, and network interfaces that are not registered in DNS can still perform dynamic updates


View products that this article applies to.

Symptoms

After you install Microsoft Windows Server 2003 on a "multihomed" domain controller that is a DNS server, clients may not be able to log on, and network interfaces that are not registered in DNS can still perform dynamic updates. (A "multihomed" domain controller is a computer that has multiple network adapters or that has been configured with multiple IP addresses for a single network adapter.) This problem occurs on domain controllers with new (non-upgrade) installations of Windows Server 2003 and on computers that have been upgraded to Windows Server 2003 from Microsoft Windows 2000.

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Cause

This problem occurs because if you clear the Register this connection's address in DNS check box under Advanced TCP/IP Settings for one of the network interfaces and then restart the Netlogon service, the Netlogon service ignores the settings. The client computer that tries to connect to one of the multihomed interfaces for the domain controller may have no valid IP route.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
   Date         Time   Version           Size     File name
   -----------------------------------------------------------
   08-Jan-2004  21:33  5.2.3790.116 shp  151,552  Dnsapi.dll
   08-Jan-2004  21:33  5.2.3790.116 shp  419,328  Netlogon.dll
Windows Server 2003, 64-Bit Edition
   Date         Time   Version           Size     File name
   ----------------------------------------------------------------
   08-Jan-2004  12:33  5.2.3790.116 shp  415,744  Dnsapi.dll
   08-Jan-2004  12:33  5.2.3790.116 shp  958,976  Netlogon.dll
   08-Jan-2004  12:33  5.2.3790.116 shp  151,552  Wow\Wdnsapi.dll
   08-Jan-2004  12:33  5.2.3790.116 shp  419,328  Wow\Wnetlogon.dll
After you apply this hotfix, only network interfaces that have dynamic update registration enabled appear in the Netlogon.dns file. Therefore, you can disable the dynamic update registration of A records on a per-interface basis on a domain controller. (The list of records that Netlogon tries to register is stored in the %SystemRoot%\System32\Config\Netlogon.dns file. This log file lists records that are required to be registered for the domain controller.)

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Windows Server 2003 Service Pack 1.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbwinserv2003sp1fix, kbbug, kbfix, kbwinserv2003presp1fix, kbautohotfix, KB832478

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Article Info
Article ID : 832478
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 375