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An e-mail message that you send to a dynamic distribution list is not delivered successfully in Exchange Server 2003


View products that this article applies to.

Symptoms

When you try to send an e-mail message to a dynamic distribution list, Microsoft Exchange Server 2003 does not deliver the message successfully. Instead, the e-mail message remains in the Messages awaiting directory lookup queue.

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Cause

This problem may occur if all the following conditions are true:
  • You send an e-mail message to a large dynamic distribution list.
  • The Exchange Streaming Database is stored on a network drive. For example, the Exchange Streaming Database is stored on a Network Attached Storage (NAS) device.

    Note The Exchange Streaming Database is also known as the .stm database file.
  • The Installable File System (IFS) file in the Exchange Streaming Database has more than 896 fragments.
  • The Exchange Installable File System (ExIFS) service tries to create a temporary file in the folder where the Exchange Streaming Database is located.
If you send an e-mail message to a large distribution list, the property stream may be sufficiently large that the Exchange transport must write the property stream to an IFS file instead of to the memory buffer. If the IFS file has more than 896 fragments, ExIFS converts the scatter list to "large buffer" mode. Then, ExIFS moves the scatter list to a temporary file that is in the same folder as the Exchange Streaming Database. When the Exchange Streaming Database is located on a network drive, the call to create the temporary file may fail.

Note A scatter list keeps track of the offsets and the length of each fragment of an open IFS file that are "scattered" in the larger Exchange Streaming Database.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the Microsoft Exchange Information Store service and the ExIFS service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ---------------------------------------------------
   17-Dec-2003  01:34  6.5.6980.56  195,840  Exifs.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB832425, kbexchange2003presp1fix, kbbug, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 832425
Revision : 10
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 266