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System Attendant service quits when you edit the Lotus Notes proxy address of a user


View products that this article applies to.

Symptoms

When you edit the IBM Lotus Notes proxy e-mail address for a user by using the Active Directory Users and Computers snap-in, the Microsoft Exchange System Attendant service (Mad.exe) quits unexpectedly. Additionally, the following event may be logged in the Application event log:

Event ID: 1000
Raw Event ID: 1000
Record Nr.: 505
Category: None
Source: Microsoft Exchange Server
Type: Error
Machine: ServerName
Message: Faulting application mad.exe, version 6.5.7226.0, stamp 406d1e9b, faulting module ntspxgen.dll, version 6.5.6944.0, stamp 3edc4c66, debug? 0, fault address 0x0000251e.

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Cause

This problem may occur if the Microsoft Exchange System Attendant service cannot access the Ntsxpgen.dll file during the initialization of the Microsoft Exchange System Attendant service.

The Ntsxpgen.dll file is included with the Microsoft Exchange Connector for Lotus Notes. By default, the Ntsxpgen.dll file is stored in the following folder:
C:\Program Files\Exchsrvr\Address\Notes\I386
If the Microsoft Exchange System Attendant service cannot access this file during the service startup but later can access this file, the Microsoft Exchange System Attendant service quits when you try to edit the Lotus Notes proxy address for a user or a Lotus Notes contact.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, the following services are automatically stopped and then restarted during the hotfix installation:
  • Microsoft Exchange MTA Stacks
  • Microsoft Exchange Information Store
  • Microsoft Exchange System Attendant

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
18-Nov-2003  03:50  6.5.6980.43        36,864  Ntspxgen.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: KB831187, kbqfe, kbfix, kbbug, kbexchange2003presp1fix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 831187
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 264