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Web content does not appear, or clients receive an "HTTP 502 Proxy Error" message when they try to access external Web sites with ISA Server 2000


View products that this article applies to.

Symptoms

When Web browser clients that are located behind Microsoft Internet Security and Acceleration (ISA) Server 2000 try to access external Web sites, they may receive a red "X" instead of some content, or they may receive the following error message:
HTTP 502 Proxy Error - The ISA Server denies the specified Uniform Resource Locator (URL). (12202) Internet Security and Acceleration Server.

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Cause

This problem may occur if a site and content rule in ISA Server is configured to only allow certain content groups. A Content-type header does not have to be specified in certain HTTP responses, such as in HTTP responses that must not include a message-body in the response. For example, "304 Not Modified" responses must not include a message-body. If ISA Server is configured to only allow certain content groups, it denies any response that does not have a Content-type header, unless the requested file name extension is allowed in the content group. This configuration causes certain responses, such as "304 Not Modified," to be denied even though these responses must not contain a message-body and therefore do not have to specify a Content-type header.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. For additional information about how to obtain the latest ISA Server service pack, click the following article number to view the article in the Microsoft Knowledge Base:
313139 How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Prerequisites

To apply this hotfix, you must have ISA Server 2000 Service Pack 1 (SP1) installed on your computer.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time    Version      Size     File name
   --------------------------------------------------------
   16-Dec-2003  17:21  3.0.1200.298  393,488  W3proxy.exe
   16-Dec-2003  17:21  3.0.1200.298  299,280  Wspsrv.exe
   16-Dec-2003  17:21  3.0.1200.298  178,448  Mspadmin.exe
   16-Dec-2003  17:21  3.0.1200.298  103,184  Msphlpr.dll
This hotfix also applies to the following language versions of ISA Server 2000:
  • French
  • German
  • Spanish
  • Japanese

Implement the hotfix

After you apply the hotfix that is described in this article, follow these steps to implement the functionality in this hotfix.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Stop the Web Proxy service.
  2. Start Registry Editor.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3Proxy\Parameters
  4. Create the following new entry:
    Entry name:
    IgnoreMimeCheckForZeroContentLength

    Type:
    DWORD

    Value:
    1
  5. Start the Web Proxy service.
To revert to the original configuration, either remove the
IgnoreMimeCheckForZeroContentLength
registry entry, or change its data value to 0 (zero). After you make either change, restart the Web Proxy service.

After you apply the hotfix that is described in this article and then create the registry entry, ISA Server will not check the content group for any HTTP response with a 100 HTTP status code, a 204 HTTP status code, or a 304 HTTP status code unless a Content-type header is also specified in the response. ISA Server will allow these responses because the responses must not include a message-body and therefore do not require a Content-type header. ISA Server will also allow any other HTTP response without a Content-type header if that response also has a Content-length header of 0. However, if the response contains a Content-type header, ISA Server will apply restrictions that are based on the content groups that are allowed in the site and content rule. Additionally, if the response has no Content-type header, and if the Content-length header is not 0, ISA Server will apply content group restrictions for all HTTP responses, including the 100 HTTP status code, the 204 HTTP status code, and the 304 HTTP status code.

If a Web server incorrectly sends a message-body in an HTTP response with a Content-length header of 0, ISA removes the message-body from the response before ISA sends only the HTTP response headers back to the Web Proxy client. This behavior also occurs with HTTP responses that include a Content-type header if that content type (or the requested file name extension if there is no Content-type header in the response) is specified in the content group that is allowed. This behavior only occurs after the hotfix is applied and after the
IgnoreMimeCheckForZeroContentLength
registry entry is created.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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Keywords: KB831140, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 831140
Revision : 7
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 288