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You cannot connect over the Internet to Exchange Server 2003 from Outlook 2007 or from Outlook 2003


View products that this article applies to.

Symptoms

When you try to use Microsoft Office Outlook 2007 or Microsoft Office Outlook 2003 to connect over the Internet to your mailbox on a Microsoft Exchange Server 2003 based-computer, you are prompted for your logon credentials many times, and you do not connect to Exchange Server 2003.

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Cause

This behavior occurs if an outbound proxy authentication is required, and if you use Remote Procedure Call (RPC) over HTTP to connect to an Exchange Server 2003 account. When Outlook is using RPC over HTTP, the default timeout is 45 seconds. If RPC over HTTP takes longer than 45 seconds to connect, the connection is not successful.

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Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To resolve this behavior, you can add the ConnectTimeout, the ConnectTimeoutLow, and the RFRTimeoutDWORD values to the RPC registry key. To do this, follow these steps.

Note All the "connect timeout" registry values that are mentioned in the following steps are expressed in milliseconds (ms).
  1. Click Start, and then click Run.
  2. In the Open box, type Regedit, and then click OK.
  3. Expand the following registry key:

    Outlook 2003
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\RPC
    Outlook 2007
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC
    Outlook 2010
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\RPC
  4. Right-click RPC, point to New, and then click DWORD Value.
  5. Type ConnectTimeout, and then press ENTER to name the new value.
  6. Double-click ConnectTimeout.
  7. In the Value data box, type 000493e0, and the click OK.
  8. Right-click RPC, point to New, and then click DWORD Value.
  9. Type ConnectTimeoutLow, and then press ENTER to name the new value.
  10. Double-click ConnectTimeoutLow.
  11. In the Value data box, type 000493e0, and the click OK.
  12. Right-click RPC, point to New, and then click DWORD Value.
  13. Type RFRTimeout, and then press ENTER to name the new value.
  14. Double-click RFRTimeout.
  15. In the Value data box, type 000493e0, and the click OK.
  16. Exit Registry Editor.

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More information

When Outlook tries to connect to each server type, Outlook uses the registry values that you added in the Resolution section to determine how long to wait before the connection is considered a failed connection (a time-out connection) and the connection is dropped.
  • Outlook uses the ConnectTimeout registry value when it detects connections that use a network adaptor that is functioning at greater than 128 kbps.
  • Outlook uses the ConnectTimeoutLow registry value when it detects connections that use a network adaptor that is functioning at less than 128 kbps.
  • Outlook uses the RFRTimeout registry value for a server referral. For example, Outlook uses this value when it asks the Exchange store for a referral to the global catalog server, to another user’s mailbox, or to a public folder. Outlook uses this registry value for all network adaptor speeds that are detected.
Outlook uses these registry values to determine how long to wait for a connection to succeed before Outlook times out and the connection fails.

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Keywords: kbpending, kbprb, KB831060, kbpending, kbprb, KB831060

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Article Info
Article ID : 831060
Revision : 6
Created on : 9/20/2011
Published on : 9/20/2011
Exists online : False
Views : 509