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The Directory Service Access component, the Recipient Update Service component, and the Categorizer component do not time out as expected in Exchange 2000 Server or in Exchange Server 2003


View products that this article applies to.

Symptoms

The following components in Microsoft Exchange 2000 Server and in Microsoft Exchanger Server 2003 do not time out within the expected time limit when a delay occurs:
  • Directory Service Access (DSAccess)
  • Recipient Update Service (RUS)
  • Categorizer
When they time out, the stores on Exchange Server dismount.

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Cause

This problem occurs because the timeout value for these components is incorrectly multiplied by 1,000 when the ldap_set_option command is used to set the LDAP_OPT_SEND_TIMEOUT Lightweight Directory Access Protocol (LDAP) option. The ldap_set_option command is called with a value in milliseconds. However, a value in seconds is expected.

The LDAP_OPT_SEND_TIMEOUT option is expected to set the limit on the number of seconds that the local LDAP client will wait while trying to send data to a remote computer. If the send operation is not completed before the timeout period expires, the LDAP call will fail with an LDAP_TIMEOUT error code.

The default timeout value for Directory Service Access is 30. This value is incorrectly multiplied by 1,000 and is set to the value of 30,000 seconds. 30,000 seconds equal 8 hours and 20 minutes.

The default timeout value for Recipient Update Service is 180. This value is incorrectly multiplied by 1,000 and is set to the value of 180,000 seconds. 180,000 seconds equal 50 hours.

The default timeout value for Categorizer is 30. This value is incorrectly multiplied by 1000 and is set to the value of 30,000 seconds. 30,000 seconds equal 8 hours and 20 minutes.

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Resolution

Exchange Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ---------------------------------------------------------
   26-Nov-2003  03:59  6.5.6980.49  581,632  Abv_dg.dll       
   

Exchange 2000 Server hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Exchange 2000 Server Service Pack 3 (SP3). For additional information about Exchange 2000 Server Service Pack 3, click the following article number to view the article in the Microsoft Knowledge Base:
301378� How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   --------------------------------------------------------
   12-Nov-2003  02:42  6.0.6535.0  602,112  Abv_dg.dll       
   

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB830906, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 830906
Revision : 8
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 270