Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects


View products that this article applies to.

Symptoms

Your Microsoft Exchange Server 2003 computer may stop responding to one or more clients. Additionally, an error message that is similar to the following may be logged in the application event log:

Event ID: 9646
Type: Error
Source: MSExchangeIS
Description:
Closing Mapi session "/o=Organization/ou=Administrative Group/cn=Recipients/cn=user" because it exceeded the maximum of 250 objects of type "objMessage".



Note The description of this event may vary depending on the object type.

↑ Back to the top


Cause

This problem may occur if a MAPI client opens more than the default value of the following server objects:

Note Microsoft Exchange Server 2003 Service Pack 1 (SP1) increased the default value of several server objects. The increased values are shown in the "SP1 and later service packs" column in the following table.

EntryDefault ValueSP1 and later service packs
objtMessage250250
objtFolder500500
objtAttachment100500
objtFolderView500500
objtMessageView500500
objtAttachView250500
objtStream50250
objtACLView5050
objtRulesView5050
objtFXSrcStrm5050
objtFXDstStrm5050
objtCStream5050
objtNotify500,000500,000

↑ Back to the top


Resolution

In Exchange Server 2003, the number of server-side objects that are allowed by clients is limited to prevent a single client from the exhausting resources on the Exchange server. When the event log error that is mentioned in the "Symptoms" section occurs, it indicates possible poor behavior on behalf of a client opening too many objects or leaving too many objects open on the server. If the event log error occurs, investigate any third-party applications or add-ins that are running on the client.

Additionally, investigate the user behavior that is associated with the indicated logon. This will help you better understand why the default number of objects is insufficient. In rare circumstances, the number of resources is insufficient and may be adjusted. However, use caution before you adjust the maximum number of objects that are allowed. When you increase the maximum number of objects of a particular type, you also increase the amount of memory that may be consumed by client requests. Incorrectly configuring this value could lead to out-of-memory warnings or virtual memory fragmentation warnings.

You can add a registry key that adjusts the maximum number of resources that a MAPI client can use at the same time. This adjustment overrides the default limit of each server object that is mentioned in the "Cause" section.

Note You should only adjust the value for the object type that is referred to in the event log error that is mentioned in the "Symptoms" section. You should adjust these values with caution, and only increase the value in small increments. For example, only adjust the value by 100.

For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To add a registry key that limits the maximum number of resources that a MAPI client can use at the same time, follow these steps:
  1. Click Start, click run, type regedit, and then click OK.
  2. Expand the following registry subkey:
    \\HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
  3. Right-click ParametersSystem, point to New, and then click Key.
  4. Type MaxObjsPerMapiSession, and then press ENTER to name the new subkey.
  5. Right-click MaxObjsPerMapiSession, click New, and then click DWORD Value.
  6. Type Object_type, and then press ENTER to name the object.

    Note Object_type is the name of the object type in the error message that is mentioned in the "Symptoms" section. For example, type objtMessage, and then press ENTER.
  7. Right-click Object_type, and then click Modify.
  8. In the Value data box, type the number of objects that you want to limit this entry to, and then click OK. For example, type 350 to increase the value for the objtMessage object. The default value is 250.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB830829, kbprb, kbbug

↑ Back to the top

Article Info
Article ID : 830829
Revision : 5
Created on : 9/3/2013
Published on : 9/3/2013
Exists online : False
Views : 256